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INTRODUCTION
Microsoft Excel is a spreadsheet tool that permits and enables people to
organize and calculate their data through using mathematical formulas. Just
like other Microsoft Office products, Microsoft Excel is now presented as a
cloud-based subscription service through Office 365. Most top companies
and organizations use Microsoft Excel and it is a very good way to simplify
your organizational data.

The software can be used on Mac OS and Windows and it allows users to
carry out operations including creating pivot tables, performing basic
mathematical operations, writing data using the action pen, unhiding
multiple worksheets, working with columns and rows, and so much more.

In addition, this guide will take you on a roller-coaster ride to discovering
the new Microsoft Excel 2022, including how best to work with formulas
and different functions. Get this guide and begin your Microsoft Excel
journey.

 



CHAPTER ONE

What’s new in Excel?

 

Unhide multiple worksheets



It was always possible to conceal many sheets with a single command.
Unhiding sheets, on the other hand, had to be done one at a time. A new
Unhide dialog box lets you to use Ctrl or Shift to select numerous
worksheets and unhide them all at once.

 

Browse during Save As
When you execute a Save As command, a folder path is now shown at the
top of the center part of the backstage view. (NB: This folder is clickable
and opens the File Explorer instantly).

Clicking this item at the top will take you directly to the File Explorer. Yes,
clicking the Browse symbol at the bottom of the left panel does the same
thing. However, you will discover that selecting the route at the top of the
screen is more convenient and efficient than searching for Browse at the
bottom of a lengthy list of file locations.

 

Searching while opening workbooks

When you choose File > Open to launch a workbook, Excel displays the
workbooks you’ve pinned to the list, followed by the latest 10 to 50
workbooks. It may be a workbook that you used every other week, but
when you open dozens of files on a given day, such workbooks get moved
to the bottom of the list.

The new Search bar at the top of the screen performs well. If you type a
word or two from the workbook name, Excel will give it to you if you’ve
recently opened the workbook.

 



Excel opens quicker

Microsoft unveiled a new design for Office. While the rounded edges may
not seem interesting, the reality is that Excel is now loading significantly
quicker than it was before. The new splash screen displays for a few
seconds before the grid shows.

 

Smooth scrolling for tall or wide cells

In Excel, a single cell may carry almost 32 thousand characters. Some
individuals keep paragraphs in a cell. The row height may be increased to
409.5 and the column width to 254.9.

Assume you have a spreadsheet with 50 rows of paragraphs with a height of
400. When you scroll with the wheel mouse, Excel will advance three rows
at a time even if only one or two rows are displayed on the screen.

People who store this much info in a cell have been asking for a method to
scroll slowly. In You can scroll one character left or right at a time by
pressing Ctrl+Shift+Wheel Mouse.

Another notable enhancement is that if you let off of the scroll wheel or
scroll bar, Excel will remain “parked” in the current view, even if you are
halfway through a cell. Previously, if you scrolled halfway through a cell,
Excel would redraw the screen such that the window began at the top of
that cell or the top of the following cell.

 

Show changes from last 60 days

Excel begins recording every modification made to a worksheet as soon as
you save a workbook to OneDrive or SharePoint Online.



These modifications are accessible for 60 days. This gives an excellent
audit trail for determining who updated a cell, when they changed it, and
what the new value was.

Open the worksheet in Excel Online to view the changes.

Select Show Changes from the Review tab.

However, if someone modifies one of the formulae, such as modifying the
calculation for June, the change will be recorded.

 

Image transparency
Images in Excel are shown on a drawing layer above the grid. This implies
that any picture will obscure the data behind it. On the Picture Format tab of
the ribbon, a new Transparency icon emerges. Increase the transparency of
the image so that you can see the info behind it.

 

Write data using the Action Pen
This is one of Excel’s strange features. Sometimes a new feature is added to
Excel because the PowerPoint developers created something that was
simple to convert to Word and Excel. The Action Pen seems to fall under
that group.

First, in the ribbon, there is a Drawing tab. A few years back, they made a
big fuss about introducing new pens to the Drawing tab—glitter pens, pens
of all kinds. In 2020, they will include an Action Pen.

When you use an Action Pen, you may utilize a mouse or a touchscreen to
handwrite your data. The handwriting is transformed to data as if you had



typed it a few seconds later.

 

Cut-out people

On the Insert tab, choose the Icons command. There are several new icons,
as well as stickers and a vast collection of cut-out individuals. Excel
provides 20-30 postures for each of 40 stock individuals. They have a
translucent backdrop, as the name implies, so you may place the individuals
next to or on top of your data.

Cutout People may be searched by mood or trait, such as Smiling, Happy,
Angry, Pointing, Holding a Sign, and so forth.

 

 

 

The ribbon has rounded edges

When Microsoft revealed a new design for the ribbon and then sent it out to
no one for a week, there was a lot of social media enthusiasm. Everyone
who was eager to view the new ribbon was attempting to update their
Microsoft 365 hourly in order to see the new ribbon.

When it eventually came, the big deal was the rounded corners. Everything
now has a circular curve to the edge, rather than squared-off tab titles.

Undo and Redo have been relocated from the Quick Access Toolbar to the
left side of the Home tab. This implies that if you use the Insert, Draw, Page
Layout, or other tabs, you should have no problems.



When you drag the Quick Access Toolbar below the ribbon, you can see the
name of each icon. This is really very helpful. It does, however, imply that
Microsoft renamed all 2,500+ icons to improve their appearance in the
Quick Access Toolbar. (NB: This makes customizing the ribbon or the
Quick Access Toolbar more difficult. Previously, all five Speak Cells
commands were housed in the “S” section).

 

New Lambda helper functions
LAMBDA functionalities is another new feature added to Excel. As they
began to roll out to more users, Microsoft discovered that they required a
set of auxiliary functions to make Lambda functions simpler to utilize.

However, these brand-new auxiliary functions are only detailed here. They
will most likely not be available to the broader Microsoft 365 audience until
2022.

 

Each of these new functions will loop over a range, passing each cell, row,
or column to a LAMBDA function written as the helper function’s last
parameter.

Your objective is to create a rectangle array with 12 rows and 5 columns.
=MAKEARRAY(12,5,LAMBDA(...)) is the first line of the formula. In this
scenario, the LAMBDA function takes three arguments:

The first parameter is a variable that stores the row number of each
array item.

The second parameter is a variable that stores the column number of
each array item.



The third parameter is formula logic, which converts the row and
column into the value for that array member.

 

This group also includes the following functions:

MAP: Call the MAP function with a range or an array and a
LAMBDA. Excel will apply the LAMBDA function to each
element in the input range and generate an array of the same size as
the incoming array.

 

REDUCE: To the MAP function, provide a range or an array as
well as a LAMBDA. An accumulator variable is required by the
LAMBDA to keep the final outcome, the incoming array, and
finally the logic. Each element in the incoming data is subjected to
the logic, and the results are added to the accumulator. For example,
the logic may count the number of components that fall between 3
and 9. REDUCE always yields a single result.

 

SCAN is identical to REDUCE, except it provides an array of all
intermediate responses instead of a single answer. REDUCE
delivers a single result if the entering array has four rows and three
columns. SCAN will yield 4 rows and 3 columns, with interim
findings shown after each phase.

 

BYROW and BYCOL apply a LAMBDA to each row and column
of an input array, respectively. BYROW is ideal for finding the
MAX value in each row of a rectangular array.



 

Accessibility tab in ribbon and the navigation pane
Excel has an accessibility checker and clearly shows “Check
Accessibility” on the left side of the Status Bar. When you launch the
Accessibility Checker, a new tab called Accessibility appears on the ribbon.
The tab provides a variety of options that may be used to resolve issues
discovered in the Accessibility pane.

Consider navigating a workbook with little eyesight. Microsoft spoke with
users who use a screen reader with Excel and discovered that it is tough to
gain your bearings to find out where the data and pivot tables are situated.

Microsoft has now brought the Navigation pane to Excel. Worksheets,
named ranges, charts, contiguous data ranges, and pivot tables will be
shown on the pane. Select View, Show, Navigation to bring up the
Navigation window. The concept is that a screen reader user may utilize the
navigation pane to discover important parts of the worksheet and go to the
appropriate one.

 



CHAPTER TWO

How to customize Excel
 

Sharing customizations with others
You can export all ribbon modifications if you’ve created the ideal ribbon
customization and want everybody in your team have the same one.

Follow these procedures to export the changes:

1. Right-click the ribbon and choose Customize The Ribbon from the
menu that appears.

2. Choose Import/Export > Export All Customizations from the list
box on the right.

3. Navigate to a folder and name the customization file. (NB: The file
extension will be.exportedUI. Click the OK button).

4. Locate the.exportedUI file in Windows Explorer. Transfer it to a
coworker’s PC.

5. Repeat step 1 on the coworker’s PC - Choose Import
Customization File. Locate the screen and select OK.

(NB: You can’t export modifications to a single custom tab without also
exporting changes to the Data and Home tabs).

 

Adding a new ribbon tab



Follow these simple steps to install a new ribbon tab:

1. Right-click the ribbon and choose Customize The Ribbon from the
menu that appears.

2. Select New Tab and rename it.

3. Insert New Group(s) into the new tab.

4. Add commands to the newly created groups.

(NB: While you go through the processes to create a new ribbon tab,
you’ll see how severely limited the ribbon modifications are).

Also, you have no influence on which goods have huge icons and which
have tiny ones. This is true even for galleries. When you add the Cell Styles
gallery to a ribbon group, it always displays as an icon rather than a gallery,
even if it is the only object on the whole ribbon tab. Add a complete built-in
group to the tab as a workaround. The complete Styles group was added to
the right of.

 

Furthermore, you cannot decide which icons seem big and which appear
tiny on the ribbon when modifying it using this interface.

The Excel ribbon is organized logically, with big icons for key functions
and little icons for lesser ones. When you establish a new group, you have
no choice over which icons are little and which are huge.



To design custom ribbon tabs, you may either learn RibbonML or utilize a
third-party application like Ribbon Commander.

 

Options to consider
Although there are hundreds of Excel choices available, this section gives a
fast overview of several that may be useful to you:

1. Select Save Files In This Format from the Save menu. If you often
develop macros, make Excel Macro-Enabled Workbook your
default format type.

 

2. On the Save tab, change your Default Local File Location. Excel
will always save new documents to your My Documents folder.
However, if you usually work in the C:AccountingFiles folder,
change the default location to match.

 

3. This option “Show This Number Of Recent Workbooks” has been
significantly improved since Excel 2003. Unlike previous versions
of Excel, which displayed up to nine recent workbooks at the
bottom of the File menu, Excel now displays up to 50 recent
workbooks in the Open category of the File menu. (NB: You may
alter this option by going to the Advanced category’s Display
section).

 

4. Edit Custom Lists has been relocated to the Advanced category’s
General section. Custom lists extend the capability of the fill
handle, allow for custom sort orders, and govern how fields are



presented in a pivot table’s label area. In a worksheet, type a list in
the right order. Click Import after editing Custom Lists. Excel can
now extend items from that list automatically, just as it can extend
January into February, March, and so on.

 

5. Make Excel appear less like Excel by hiding interface components
in the Advanced category’s three Display sections. The formula bar,
scrollbars, sheet tabs, row and column headers, and gridlines may
all be disabled. Except for the File menu, you may configure the
ribbon to eliminate all primary tabs. The objective is that if you
create a model for someone who has never used Excel, that person
can open the model, enter a few numbers, and obtain the result
without having to view the complete Excel interface.

 

6. Show a Zero under Cells with No Value is in the advanced
category’s Display Options for This Worksheet section. People
sometimes request that zeros be shown as blanks. Although a
custom number format of 0;-0; will do this, you can modify the
setting worldwide by unchecking this box.

 

7. Group Dates in the AutoFilter Menu appears under the Advanced
category’s Display Options For This Workbook section. Beginning
with Excel 2007, date columns in the AutoFilter drop-down menu
display a hierarchical view of years, months, and days. Turn off this
feature if you prefer the former habit of displaying each date.

 



8. Make a trusted location out of a folder on your local hard disk. Files
saved at a trustworthy place have macros enabled and external links
updated automatically. If you are certain that you will not create
harmful code, set up a trusted place on your hard drive. Pick the
Trust Center category and then Trust Center Settings from the
Excel Options menu. Select Trusted Locations, Add New
Location from the Trust Center.

 

 

 

 

Using the Excel Options dialog box





To launch the Excel Options dialog box, open the File menu and pick
Options from the left navigation pane. General, Formulas, Data, Proofing,
Save, Language, Ease Of Access, Advanced, Customize Ribbon, Quick
Access Toolbar, Add-Ins, and Trust Center are the categories in the dialog
box. The Trust Center provides access to an additional 13 categories.

To their credit, the Excel team attempted to relocate the top selections to the
General category. Beyond those 19 options, there are hundreds more
distributed throughout 24 categories in the Excel Options and Trust Center.

 



Excel’s most recent new features
Excel now has numerous additional options:

1. Multiple Displays is now seen in category General. Excel now
accepts newer High DPI screens, although many users still use two
monitors, one with a High DPI display and the other with an older
display. (NB: If you’re having trouble transferring Excel between
screens, choose Optimize for Compatibility from this menu).

 

2. Excel included data types for stocks, currencies, and geography,
among other things. If you add city names into a few cells, Excel
will propose to convert those cells to a Geography Data Type in an
attempt to make the feature more discoverable. This is fantastic at
first, but if it annoys you, uncheck the box next to Show Convert
To Data Types When Typing in the General category.

 

3. In the title bar of Excel, there is a Search box. This is used for
locating instructions that are not shown on the ribbon. Select
Collapse the Microsoft Search Box by Default if you believe the
Search box is taking up too much space.

 

4. Excel now has a dark mode, thanks to Microsoft. In the General
category, choose the Office Theme drop-down option.

 

5. Near the bottom of the General category, you may choose which
file extensions will open in Excel and request that Excel alert you if
it is not the default software for.XLSX and.XLSM files.



 

6. The Implicit Intersection behavior has changed after the
introduction of Dynamic Arrays. If you try to create a formula with
@ in the incorrect locations, Excel will notify you that the formula
is incompatible with previous versions of Excel. It proposes
changing the formula to make it backward compatible. To test any
random formula, type =@(the formula) into Excel and see whether
a dialog box appears. To disable this behavior, uncheck Suggest
Formula Variations That Are Supported By Older Versions of Excel
in the Formulas category.

In the Formulas category, there are two new error-checking options. If your
formula leads to a numeric cell but is represented as a date, a warning about
a Misleading Number Format occurs. The number format from the source
cell will be replicated to the formula cell if you choose Update Format.
Cells Containing Data Types That Couldn’t Refresh is another new error-
checking option. (NB: If the associated data type cell could not be
updated, you will be warned).

Other options include:

1. The new Data category has the Default PivotTable Layout. Make
this the default layout for all future pivot tables. Several items in the
new Data category were transferred from the Advanced category
to the Data category.

 

2. Demonstrate Legacy Data Import Wizards is a set of seven
options under the newly created Data category. Excel 2016 saw the
introduction of the Power Query capabilities on the Data tab of the
ribbon. Because these tools were so popular, Microsoft chose to



remove the old Get External Data category from the ribbon,
although some customers preferred the old symbols for special
reasons. Choose From Access, From Web, From Text, From SQL
Server, From OData Data Feed, From XML Data Import, or From
Data Connection to re-add those old icons. If you choose an item
from this section, it will appear concealed on the ribbon. Look in
Data, Get Data, and Legacy Wizards are all options.

 

3. Display a Data Loss Warning when Comma Delimited Files
(*.csv) are detected in the Save category. Excel used to annoy you
every time you opened a CSV file. If you did not save the file as
XLSX, it would alert you that your formulae and formatting are
going to be lost. Many people were fed up with the pestering, so
Microsoft disabled it by default. You may reactivate it here if you
need to be nagged.

 

4. A new Cache Settings option in the Save category governs how
long files are kept in the Office document cache and allows you to
delete it.

 

5. Excel 2019 introduces a new area called Ease of Access. You have
the option of providing feedback with sound and selecting a
Modern or Classic sound design. The Modern sound design is the
new addition. Previously, the only option in the Advanced category
was the irritating Classic Sound Scheme. The option to decide
whether Screen Tips are shown is replicated from the General



category here. You may change the Default Font Size used in the
document and turn off the Calculation Function Screen Tips.

 

6. Select and interact with the pen By Default is a new category in the
Advanced section. If you want to use a touchscreen, you may
modify the default touch behavior.

 

7. Hyperlinks to cloud-based Excel files can open in Excel Online.
There is a new feature that allows you to open them in the desktop
edition of Excel. The Link Handling subcategory is the Advanced
category’s third subsection. Select Open Supported Hyperlinks
To Office Files In Desktop Apps from the menu.

 

8. Excel allows you to choose how many recent files display when
you select File > Open. (NB: The new Find Show This Number
Of Recent Unpinned Folders option determines how many recent
folders are shown).

 



 



CHAPTER THREE

How to use the Excel Interface

How to use the full-screen File menu

To access the Backstage view, go to the File menu and choose Backstage.
Here’s how it works: You are working in your document when you work on
most ribbon tabs. When you are ready to alter the font or anything similar,
you want to check how the change will affect your work.

As a result, Microsoft refers to them as “in” instructions. The Excel team,
on the other hand, believes that when you go to the File menu, you are
finished working in your document and are going to do anything with the
whole document, such as transmit the workbook, print the workbook,



export to PDF, and so on. These are referred to as “out” instructions by
Microsoft. Because the “out” instructions do not require seeing the
worksheet, Microsoft covers the full screen with the File menu.

Click the File menu to get the Backstage view. The Backstage view
takes up the whole screen. Backstage is divided into three areas: the
tiny left navigation panel and two broader information sections.

The following commands are available in the left navigation panel:

Home: A new update to the File menu, Home joins New and Open
features. At the top, you’ll find Microsoft lessons and popular
templates. In the center, you’ll see recent files, pinned files, and
files that others have shared with you.

Info: This section contains information on the current workbook. 

New: Used to start a new workbook or workbook from a template.

Open: This command is used to access a file on your computer or
in OneDrive.

Save: This option saves the file in the same folder where it was
previously saved. (NB: In Backstage, Save is a command rather
than a panel).

Save As: This option saves the file to your PC or to OneDrive.

Print: Used to select and print settings. Print Preview is included.

Share: This is now the place where you may share a workbook with
your colleagues.

Export: This function is used to produce a PDF or to alter the file
format.

Publish: This option is used to publish your worksheet to Power BI.



Close: This command closes the current worksheet. This item, like
Save, is only a command.

Account: Log in to the Office. Select a color scheme and a
backdrop. Check to see if there are any updates available. Learn
how to use your specific version of Excel. This and the following
two items have been relocated to the bottom left of the screen, under
the area.

Options: This section has pages of Excel settings.

Recent File List: This list displays only if a default option in Excel
Options has been altered. Select Quickly Access This Number Of
Recent Workbooks from the File, Options, Advanced Display
menu.

 

Pressing the Esc key to close Backstage view
To exit Backstage and return to your worksheet, hit Esc or select the back
arrow in the top-left corner of Backstage.

 

Using the ribbon



Excel’s primary user interface is the ribbon. It is divided into tabs such as
Home, Insert, and so on. Each tab is divided into sections that include a
range of icons, drop-down menus, and galleries.

Following a controversial debut in 2007, the ribbon is now a part of our
everyday life, and the notion has even been adopted by other products.
After Excel 2019, Microsoft redesigned the ribbon for Microsoft 365
subscribers.

Contextual ribbon titles that were formerly two lines long, such as “Chart
Tools Design,” are now condensed to “Chart Design” on a single line. A
single thick line is visible underneath the chosen ribbon. They added
rounded edges to the formula bar and ribbon in the summer of 2021, as well
as labels to the Quick Access Toolbar when it is shown below the ribbon.

 

Using flyout menus and galleries



The gallery control is one of the ribbon’s elements. Galleries are employed
when there are hundreds of selections to pick from. The gallery displays a
visual thumbnail of each option. A gallery begins with a row or two of
options in the ribbon. The Up, Down, and Open icons are located on the
right side of the gallery. When you select Up or Down, you will scroll
through the options one row at a time.

When you click the Open control in the bottom-right corner of the gallery,
the gallery expands to offer all options at once.

 

Rolling through the ribbon tabs
With Excel open, drag the mouse anywhere on the ribbon and spin the
scroll wheel on top of the mouse. Excel swiftly moves from one tab to the
next on the ribbon. Scroll away from you to the left, toward the Home tab.
To go to the right, scroll toward you.

Using dialog box launchers, task panes, and “Extra” commands, you
can reveal more commands

 

The ribbon contains about 20% of the possible commands. The collection
of instructions and settings accessible in the ribbon will suffice for the most
of the time, but you may sometimes need to go beyond the commands in the
ribbon. This is possible using dialog box launchers, More commands, and
the task pane.

A dialog box launcher is a specific symbol that may be seen in the lower-
right corner of various ribbon groups. Click the dialog box launcher to open



a related dialog box with many more options than are available on the
ribbon.

When you touch the dialog box launcher, you are sent to a dialog box with
much more options than those accessible on the ribbon.

Many menus on the ribbon conclude with a link to locate more rules and
options; these links are denoted by an ellipsis (...). When you click an
Additional item, you will be sent to a dialog box or task pane with more
options than those provided in the ribbon.

 

Using task collapsing task panes



Many of Excel’s newest components are structured in a task pane that
shows on the right side of the screen. Previously, you could have two, three,
or four task windows open at the same time. Today, Excel compresses the
task panes so that you only see one. (NB: The remaining task panes have
been consolidated into a short strip on the right side of Excel).

By clicking any of the icons on the collapsible task pane strip, you may
switch between task panes.

What if you wanted to view all the task panes? Drag the task pane off the
left side of the screen by clicking and dragging its title. When task windows
are docked on the left side of the screen, they do not collapse.

 

Resizing Excel changes the ribbon
As the size of the Excel program window changes, so does the ribbon.
When counseling a colleague over the phone, you should be mindful of this.
You may point to your screen and instruct them to “look at the huge Insert
drop-down menu to the right of the orange phrase ‘Calculation.”
Although this makes great sense on your widescreen display, it may not on
theirs. The Cell Styles gallery has 10 thumbnails, and the Insert, Delete, and
Format buttons are shown side by side.

 

Enabling the Developer tab
If you record or create macros on a frequent basis, you may be seeking for
the VBA tools on the ribbon. They’re all under the Developer tab, which is
by default hidden. It is, however, simple to make the Developer tab visible.

 



Take the following steps:

1. Select Customize the Ribbon from the menu that appears when
you right-click the ribbon. 

2. On the right side of the screen, a lengthy list box of ribbon tabs is
shown. Except for Developer, all of them are checked. Select
Developer by checking the box next to it.

3. Select OK.

 

Activating contextual ribbon tabs
The primary tabs are the ribbon tabs that you see all the time. Depending on
what is chosen in Excel, further 23 tabs appear and disappear. Two
contextual tabs are shown only when a chart is chosen.

 

Finding lost commands on the ribbon
Time and again, the command you want is right in the middle of the Home
tab, and everything is good. However, there are occasions when you are
unable to locate an obscure command that you are certain exists someplace
in Excel.

Above the ribbon, Microsoft provides a Microsoft Search box. The search is
intended to locate commands in Excel.

Additionally, there is a fly-out menu with additional validation options.
They offer to look in the workbook for the term “validation.” (NB: They
also provide recently opened files with validation in the title).



The results of a search for “choose from a list” do not include Data
Validation. Select Objects, Lasso Select, Save As, Select Element, Show
Field List, Get Help On “Select from a List,” and Smart Lookup On “Select
From A List” are all available.

Shrinking the ribbon
Four vertical rows of space are taken up by the ribbon. This won’t be a
problem on a large display, but it may be on a little laptop.

You can reduce the ribbon by right-clicking it and selecting Collapse the
Ribbon. Alternatively, click the carat () symbol on the far right side of the
ribbon. The ribbon folds down to reveal simply the ribbon tabs. The ribbon
briefly grows when you click a tab. Choose a command or hit Esc to close
the ribbon.

To restore the ribbon to its original size, right-click a ribbon tab and
deselect Collapse The Ribbon. On the other hand, click any tab, then the
pushpin symbol in the lower-right corner of the ribbon. By double-clicking
any ribbon tab, you may easily switch between minimized and full-screen
mode.

 

How to use the new Home Screen
When you launch Excel or enter the File menu, a new Home screen
emerges. Home, New, and Open are the first three commands on the left
navigation bar. You will be in the File menu’s Home screen without having
to do anything. (NB: The Home screen contains aspects from both the
New and Open screens).



Also, you will see a notification at the top of the Home screen that says
“Good Morning,” “Good Afternoon,” or “Good Evening.”

Beneath that message are the tiles that are typically shown when you pick
New. Blank Workbook is the initial tile. Following that are a few tiles with
Excel lessons and then several tiles with popular templates. In the New
screen, a hyperlink on the far right provides access to more templates.

The next section is titled Recommended for You. This will be six
enormous tiles of files that you have recently updated, files that others have
shared with you, or files where you were referenced in a comment.

Following that, three tabs provide Recent Files, Pinned, and Shared With
Me. This is a subset of the Open screen’s choices. (NB: It’s worth noting
that if you’ve just accessed a pinned file, it’ll appear in both the Recent
and Pinned tabs).

 

Recovering unsaved workbooks
The AutoRecover tool, as in earlier versions of Excel, make copies of your
workbook every n minutes. If you close the workbook without saving it,
you may be able to recover the file if it was open long enough to go through
AutoRecover.

If the workbook was created recently but never saved, go to the bottom of
the Recent Workbooks List and choose Recover Unsaved Workbooks.

If the workbook has already been saved, open the most recently saved
version. Go to the File menu, and you’ll see the most recent AutoSave
version from before you closed the file.

 



Delete the Recent Workbooks list
If you want to clear the Recent Workbooks list, go to File, Options,
Advanced, Display. Set the number of recent documents to zero in the
Show This Number of Documents list. After then, you may reset it to a
positive value, such as 10.

 



Getting information about the current workbook
When you open a workbook and go to File, Info, you’ll see the Info gallery
for that file. The Info pane displays a variety of information about the
current worksheet, including:

1. The route of the workbook is visible at the top of the middle panel.

2. The file size is shown.

3. You can see when the document was last edited as well as who
made the changes.

4. If there are any exceptional states, they will be shown at the top of
the center pane.

 

 

The following are examples of special states:

No Macros Enabled

No Updated Links

Retrieved from SharePoint

You may check to see whether the file has been AutoRecovered and
recover any versions that have been recovered. You could also label
the document as final, causing those who access it to see a read-only
version of the file at first.

You can change the connections to other papers.

Tags and categories can be added to the file.

You can run a compatibility checks using the Check for Issues
drop-down option to determine whether the worksheet is
compatible with older versions of Excel.



Also, you may use an accessibility checker to discover if there are
any portions of the document that will be difficult for people with
disabilities to understand.

Finally, you can use a Document Inspector to determine whether
the file contains any private information.

 



Marking a workbook as final to avoid editing
To access the Mark as Final setting, open the Protect Workbook icon in
the Info gallery. This indicates that the workbook is read-only. It prevents
others from making modifications to your final worksheet.

If the other person goes to the Info gallery, he or she may re-enable editing.
This feature is intended to notify others that you have declared it as final
and that no more modifications should be made.

You can utilize the Restrict Permission By People option if you can
persuade everyone in your workgroup to sign up for a Windows Live ID.
Also, specify who can view, change, and/or print the document using this
layer of protection.

 

Using the Document Inspector to find hidden material
The Document Inspector can detect a significant amount of concealed
material, although it is not flawless. Nonetheless, locating 95 percent of the
different sorts of hidden material might help you a lot of the time.

Take note: The Document Inspector is not impenetrable. Do you frequently
conceal settings by changing the font color to white or employing the ;;;
custom number format? The Document Inspector will not detect such
things. The Document Inspector will also ignore the fact that you navigated
beyond the print area and scribbled your post-work shopping list in column
X.

Select File, Info, Check For Issues, Inspect Document, then OK to
launch the Document Inspector. (NB: The Document Inspector findings



suggest that the document contains personal information (author’s name)
in the file properties and maybe a hidden worksheet).

 

Getting rid of the nagging regarding CSV files
The use of Comma Separated Values (CSV) is a typical method for moving
data across systems. CSV files are natively supported by Excel. CSV files
are excellent for storing data and text, but they are incapable of storing
formulae, formatting, charts, or pivot tables.

If you open a CSV file, the Excel team is scared you could add some
formulae and formatting and then forget to save as an Excel file. Excel
would constantly warn you that you were going to lose formulae and
formatting if you saved as CSV. Even if you accepted the warning and
chose to save the file as CSV, Excel would nag you again when you closed
it.

Someone who had to deal with CSV files all day made an impassioned
request on Excel.UserVoice.Com. This individual said that she was aware
that CSV files do not allow formulae, but her work required her to create
CSV files all day, every day, and she did not enjoy the continual nagging.
This concept received 1,196 votes. Nagging is now optional in Excel.

When you first attempt to save as a CSV file, the following notice shows in
the information bar above the formula bar:

POSSIBLE DATA LOSS: If you save this worksheet in the
comma-delimited (*.csv) format, certain functionalities may be lost.
To keep these features, save it as an Excel file.



You can simply disregard the notice since it displays in the information bar
rather than a dialog box. The information bar still has the Save As option,
but it now includes the Don’t Show Again button, which, when pressed,
ensures that you are never reminded about CSV files again.

If you choose Don’t Show Again and then decide you want to be alerted
about CSV files, go to File, Options, Save, and then select Show Data
Loss Warning When Editing Comma Delimited Files (*.csv).

 

Using Touch mode to provide spacing around icons
If you’re using Excel on a tablet or a touchscreen, you should attempt
Touch mode. Take the following steps:

1. Navigate to the right side of the QAT and choose an option from the
drop-down menu that displays.

 

2. Touch/Mouse Mode is the eleventh command. The icon is a blue
dot surrounded by a ring of whitespace and dashed lines. Select this
command to include it in the QAT.

 

3. Select the QAT icon by clicking on it. (NB: From there,
Whitespace has been added around all the icons).

 

Using the Quick Access Toolbar



The ribbon has a flaw in that only one-tenth of the instructions are shown at
any one moment. You’ll find yourself switching between tabs. You can also
utilize the Quick Access Toolbar (QAT) to save your favorite commands.



The QAT begins as a little toolbar with AutoSave, Save, Undo, and Redo
buttons. It is first situated in the ribbon above the File tab.

If you find yourself utilizing the QAT often, you may have to right-click it
and choose Show Quick Access Toolbar below the Ribbon to bring it
closer to the grid.

 

Including Icons in the QAT
The drop-down box on the right side of the QAT has a list of 12 common
commands that you can add to the Quick Access Toolbar. To add a
command to the QAT, choose it from the list.

When you identify a command in the ribbon that you are likely to use often,
you can quickly add it to the QAT. To do so, right-click any command on
the ribbon and choose Add to Quick Access Toolbar from the context
menu. (NB: Items added to the Quick Access Toolbar through the right-
click approach appear on the QAT’s right side).

The right-click approach is useful for many instructions, but it does not
work for specific objects inside commands. For example, you can place the
Font Size drop-down menu on the QAT, but you can’t put a font on the QAT
that is exactly size 16.

Removing commands from the QAT
By right-clicking an icon and choosing Remove from Quick Access
Toolbar, you may remove it from the QAT.

 

 



 

Customizing the QAT

The context menus allow you to make modest modifications to the QAT,
but the Customize command gives you significantly greater power over the
QAT. To open the Quick Access Toolbar portion of the Excel Options
dialog box, right-click the QAT and choose Customize Quick Access
Toolbar.

It’s worth noting that the dialog begins with a short list of Popular
Commands. To see additional options, open the top-left drop-down menu
and choose All Commands.



The Excel Options dialog box has a plethora of options for modifying the
Quick Access Toolbar:

1. Using the top-right drop-down menu, you can modify the QAT for
all documents on your computer or only the current workbook.

 

2. You can add separators between icons to properly organize them. At
the top of the left menu, there is a divider icon. In the left list box,
click the separator icon, and then in the middle of the screen, click
the Add icon.

 

3. You can also rearrange the arrangement of the toolbar icons. Click
the up/down arrow icons on the right side of the dialog box after
selecting an icon from the right list box.

4. You have access to over 2,000 commands, including those from
each tab and those not accessible in the ribbon. Despite the fact that
the dialog box opens with just 53 common commands in the left list
box, utilize the left drop-down menu to choose All Commands or
Commands Not In The Ribbon. When you discover a command
in the left list box, pick it and then click Add in the dialog box’s
center to add it to the QAT.

 

5. Use the Reset button in the bottom right to restore the QAT to its
original default setting.

 

6. You can export your personalized QAT icons from one computer
and import them onto another.



 

7. Using the check box on the bottom left, you may position the QAT
above or below the ribbon.

When the QAT is shown below the ribbon, you can choose Show
Command Labels. This functionality is presently in beta, and Microsoft
can add Command Labels when the QAT is above the ribbon as well.

 

Expanding the formula bar

The complexity of formulas ranges from extremely basic to highly
sophisticated. As individuals continued to write longer and longer formulae
in Excel, an annoyance began to emerge: if the formula for a chosen cell
was longer than the formula bar, the formula bar would wrap and stretch
over the worksheet. The formula would often conceal the first few rows of
the spreadsheet. This was particularly aggravating if the chosen cell was in
the first few rows of the spreadsheet.

Excel now features a formula bar to prevent formulas from obscuring the
document. Take note of the down-arrow symbol at the far right of the
formula bar. The formula bar is expanded when you click this button.

To enlarge the formula bar, use Ctrl+Shift+U or click the down-arrow icon
on the right side of the formula bar. The formula bar increases to the height



that was previously manually adjusted, and the whole worksheet slides
down to fit the bigger formula bar.

 

Using the new Sheet icon to add worksheets
The Insert Worksheet icon appears to the right of the final sheet tab as a
circle with a + sign.

When you click this symbol, a new worksheet appears to the right of the
current sheet. (NB: This is preferable to Excel 2010, when the new
worksheet was created as the final worksheet in the workbook and had to
be moved to its proper location).

 

Navigating through many worksheets using the controls in the lower
left

In previous versions of Excel, there were four controls for scrolling over the
list of worksheet tabs. The worksheet navigation icons are now arrowheads
to the left and right in the bottom left.

When you have more tabs than what is shown at the bottom of the Excel
window, the controls become active. To navigate the tabs one at a time,
click the left or right icon. To navigate to the first or final tab, use
Ctrl+click on any arrow. (NB: It is important to note that scrolling the
tabs does not alter the active sheet. It just brings additional tabs into view,
allowing you to click on the desired one).

You can view a full list of worksheets by right-clicking the worksheet
navigation arrows, just as you could in previous versions of Excel. To get to



a specific worksheet, click any item in the list. Shift-clicking will scroll the
tabs one “page” at a time.

An ellipsis (...) symbol displays to the left of the worksheet navigation
arrows in certain instances. The worksheet to the left of the current sheet is
selected by this icon.

 

Zooming in and out on a worksheet
A zoom slider in the lower-right corner of the Excel window allows you to
zoom from 400% to 10% with lightning speed. Simply use the slider to the
right to zoom in and the slider to the left to zoom out. The Zoom Out and
Zoom In buttons on each end of the slider allow you to zoom in and out in
10% increments.

The traditional Zoom dialog box is opened by clicking the percent
indication to the right of the zoom slider.

If you reduce the zoom to less than 40%, Microsoft believes you want an
overview of the full spreadsheet. More so, when you reduce the
magnification to 39% or less, an unusual feature shows. Any areas that have
been given a name will be represented by boxes with the name
superimposed. This is useful for gaining an overview of someone else’s
named ranges. Names that only reflect one cell will not display the name of
that cell.

 

Using the status bar to add numbers



If you select many cells with numeric data and then check at the status bar
at the bottom of the Excel window, you will see that the status bar provides
the average, count, and sum of the chosen cells.

If you need to rapidly add the contents of numerous cells, select the cells
and check in the status bar for the total. This function has been in Excel for
a decade, but few people are aware of its existence. In previous versions of
Excel, just the total was shown, but you could right-click it to view
additional values such as the average, count, minimum, and maximum.

You can choose which statistics appear in the status bar. Select any or all of
Min, Max, Numerical Count, Count, Sum, and Average from the status
bar’s right-click menu.

Sorting data

In Excel, sorting is accomplished using the Sort dialog box or by using the
AZ and ZA buttons on the Data tab.



There are six input points for sorting in total:

1. Go to the Home tab, then Editing, Sort & Filter, Custom Sort.

2. Select Sort from the menu that appears when you right-click any
cell.

3. Choose Sort from the filter drop-down option.

4. Click the Data tab, then Sort & Filter, AZ or Sort & Filter, ZA.

5. Go to the Data tab and click Sort & Filter, Sort to launch the Sort
dialog box.

Excel’s Sort dialog box supports up to 64 distinct sorting levels. When it
comes to color sorting, you often have to provide numerous criteria for one
column, thus the theoretical number of columns you may sort by is
probably less than 64.

 

Sorting by color or icon
Data may be sorted in Excel by fill color, font color, or icon set. This also
works with color applied via conditional formatting or color applied via cell
format icons.

There is no preset color sequence since color is subjective. To sort by a
single column with 17 colors, you must configure 17 rules in the Sort dialog
box.

To sort by color, do the following:

1. Choose a cell from your data set.

2. On the Data tab, click the Sort icon.

3. From the Sort By drop-down menu, choose the desired field.



4. Select Cell Color from the Sort On drop-down box.

5. In the Order drop-down box, choose the color that should be shown
first.

6. Select On Top from the last drop-down option.

7. At the top of the Sort dialog box, click the Copy Level button to
pick the next color.

8. In the Order drop-down menu for the copied rule, select the next
color.

9. Steps 7 and 8 should be repeated for each subsequent color.

10.                    To indicate that values from another column should be used
to break ties in the color column, click the Add Level button and
enter the extra columns.

11.                    To sort the data, click OK.

 

Factoring case into a sort
Usually, an Excel sort ignores the text’s case. In a sort, values that are
lowercase uppercase, or any mix of the two are considered identical.

Instead, in Excel, use a case-sensitive sort to arrange lowercase items before
uppercase ones. ABC, for example, is sorted before abc. Likewise, ABc
comes before ABC.

If you want Excel to consider case when sorting, do the following:

1. Choose a cell from your data set.

2. On the Data tab, click the Sort icon.

3. From the Sort By drop-down menu, choose the column.



4. Select the Options tab.

5. Check the Case Sensitive box.

6. To exit the Sort Options dialog box, select OK.

7. To sort, select OK.

 

Using a left-to-right sort to reorder columns
If you get a data collection from a colleague with the columns in the
incorrect order, you can either cut and paste them into the correct order or
use a left-to-right sort to repair them all in one pass.

To do this, take these steps:

1. Add a blank row above the headers.

2. In the new row, enter the numbers that match to the proper column
sequence.

3. Check that just one cell in the range is picked.

4. On the Data tab, click the Sort icon.

5. Select the Options tab.

6. Choose Sort Left to Right. To exit the Sort Options dialog box,
click OK.

7. The Classification a list of row numbers is now available through
the drop-down menu. Select the first row.

8. Values and Smallest to Largest should already be available in the
remaining drop-down choices.

9. Click OK to complete the sort.



10.                    Remove the temporary additional row from the top of the
data collection. The columns are then reordered as required.

(NB: The initial column widths are not changed by Excel. Ctrl+A selects
all cells, and then use Home, Format, AutoFit Column Width to resize all
columns).

 

Using custom lists to sort into a distinct sequence
Sometimes corporate tradition mandates that regions or goods be presented
in a non-alphabetic sequence. Geographically, the order East, Central, West
makes more sense than the alphabetic sequence Central, East, West.

It is feasible to create a custom list in Excel to inform it that the region
sequence is East, Central, and West. This sequence may then be used to sort
your data. You just need to configure the custom list once per machine.

To do so, follow these steps:

1. Open any worksheet and find a blank spot. Fill in the blanks with
the right order for the values in a column.

2. Choose this range.

3. Go to File > Options.

4. Navigate to the Advanced Group. Scroll down to the General
section and click Edit Custom Lists.

5. The bottom area of the Custom Lists dialog box displays the range
of cells you specified in step 2. If everything is in order, click the
Import button. Your new list gets added to the default custom lists
in the right order.



6. To exit the Custom Lists dialog box, click OK. To exit the Options
dialog box, click OK.

7. Delete the temporary data range created in step 1.

 

Follow these steps to utilize the list with custom sorting:

1. Choose one cell from your data set.

2. On the Data tab, click the Sort icon.

3. In the Sorting Select the area with the specified sort sequence from
the drop-down menu.

4. Select Custom List from the Order drop-down box. You should be
returned to the Custom Lists dialog box.

5. Select your own list, then click OK. (NB: The Sort dialog box
indicates that the order is determined by your own list).

6. Press the OK button to sort into the specified sequence.

 

Sorting with one click
The Sort dialog box, which is necessary for left-to-right sorting, custom
sorting and case-sensitive sorting, has been utilized in all of the examples
presented thus far in this chapter. It also facilitates color sorting. You can do
anything else by using the AZ buttons on the various tabs.

It is critical to select only one cell in the column to be sorted. When you
select a single cell in Excel, the selection is expanded to include the entire
current region. If you select two cells or the entire column, Excel warns you
that it is about to sort a portion of your data while ignoring the adjacent
data. This is almost never what you want.



The one-click sorting options are available on the Home and Data tabs.
They’re hidden under the Sort & Filter drop-down menu on the Home tab.
Also they are readily visible as AZ and ZA buttons on the Data tab.

Sorting options can also be found by right-clicking a cell in the column you
wish to sort and choosing Sort. This menu’s options allow you to sort in
ascending or descending order. You may also choose to have the cell color,
font color, or icon appear on top.

The Filter drop-down menus include additional quick-sorting choices. (NB:
These choices allow you to sort in ascending, descending, and color
order).

 

Cleaning data with Flash Fill
Assume you have a set of data with first names in column A and last names
in column B. The names are all capitalized. You want to restructure the data
such that the entire names are in correct case.

In column C, add a header. In cell C2, enter the first and last names from
A2 and B2. Excel comes into action and offers to complete the remainder of
the column for you as soon as you write the first letter in the second cell. If
the preview seems correct, or even near, hit Enter.

Excel gives two bits of feedback in addition to populating the column. To
begin, the status bar in the lower-left corner of the screen shows that Flash
Fill modified a certain number of cells.

Second, adjacent to the first altered cell, a little on-grid Flash Fill drop-
down menu symbol appears. The drop-down menu includes options like



Undo and Accept. You may also opt to choose just altered cells or only cells
that have not changed.

 

Flash Fill does not automatically fill in numbers

With just 10 digits (as opposed to 26 letters), Excel is much too likely to
discover patterns that aren’t the one you’re looking for. When Flash Fill
detects a possible pattern, it momentarily “grays in” the suggestion before
removing it. To enable Flash Fill, press Ctrl+E or select the Flash Fill
button on the Data tab.

Mathematical transformations are not understood by Flash Fill. Excel does
not know how to Flash Fill the remaining cells if the original number is 477
and you input 479 (add 2 to each cell) or 500 (round to the closest hundred).

 

Using formatting with dates
Dates are especially difficult. Assume you have a date of birth in column E
that is formatted as YYYYMMDD. When you input 3/5/1970 in G2 and
then hit the Flash Fill button, Excel does not identify the pattern properly.

In each row, you get 3/5/ and the first four numbers from E, which is an
intriguing outcome. You can see how Excel was duped into perceiving the
incorrect pattern.

(NB: To remedy the date issue, format the column to display
MM/DD/YYYYY first).



CHAPTER FOUR

Calculating with Excel and Keyboard Shortcuts

About formulas
Because spreadsheets are record-oriented, you can create a formula once
and then copy it to hundreds or thousands of cells without changing
anything in the formula.

 

Formulas versus values
When viewing an Excel grid, it is impossible to tell the difference between
a cell containing a formula and one containing numbers. Select the cell to
see if it contains a number or a formula. Examine the formula bar. If you
see a number in the formula bar, you know it’s a static value. If the formula
bar contains a formula, you can be certain that the number displayed in the
grid is the result of a formula calculation. Remember that formulas begin
with an equal sign.

 

How to enter your first formula
Your initial formula was most likely an SUM function, which you input
using the AutoSum button. This debate, on the other hand, is about a pure
mathematical formula that employs a value in a cell that is added,
subtracted, divided, or multiplied by a number or another cell.

 



Troubleshooting
Although your initial formula most certainly had an SUM function, many
individuals wrongly think that all formulas must have an SUM function.

 

If you need to multiply A2 by B2 and remove C2, use the formula =A2*B2-
C2. It is not necessary to encapsulate this formula in the SUM function as
follows: =SUM(A2*B2-C2).

Formulas may be utilized in billions of different ways. Everyday life
presents you with circumstances that can be handled with a formula. Keep
the following considerations in mind when you begin experimenting with
your own formulas:

Each formula begins with an equal sign.

Entering formulae is similar to entering equations into a calculator,
with one exception (see the next point).

If one of the words in your formula is already saved in an Excel
cell, you may point to the address of that cell rather than putting the
number into that cell. Using this approach, you can alter the value in
a single cell and then see all the formulae recalculate.

 

Creating a formula
You will want to input a formula to determine a desired sales price. Cell D2
displays the product price. You want to compute the list price in column E
as two times the cost + $3.



To input a formula, do the following:

1. Choose cell E2.

2. Enter an equal sign. The equal sign indicates to Excel that you are
beginning a formula.

3. Enter 2*D2 to indicate that you wish to multiply the value in cell
D2 by two.

4. Enter +3 to multiply the result by three. Proceed to step 5 if your
formula is =2*D2+3. Otherwise, use the backspace key to make any
necessary changes to the formula.

5. Enter your password. (NB: Excel will then compute the formula).

 

After you complete inputting a formula, Excel normally shifts the cell
cursor down or to the right. To examine the formula, return the cell
reference to cell E2. Excel displays a number on the grid, but the formula
bar exposes the formula behind the number.

 

Formulas’ relative nature



The formula =2*D2+3 literally means “multiply two by the cell to my left
and then add three.” You do not need to re-type the formula 997 times if
you need to input it in cells E3 to E999. Rather, duplicate the formula and
paste it into each cell. When you do this, Excel replicates the formula’s
essence: “Multiply two by the cell to the left of me and add three.” When
you duplicate the formula to cell E3, it gets =2*D3+3.

The ability of Excel to modify D2 to D3 in a calculation is known as
relative referencing. This is a reference’s default behavior. When detailed in
the next section, you may not want Excel to update a reference as the
formula is copied.

 

Absolute cell references override relative behavior

The flexibility of Excel to update a formula as it is copied, known as
relative referencing, is what makes spreadsheets so helpful. However, there
are situations when you require a component of a formula to always point to
a certain cell. When you have a setting at the top of the worksheet, such as a
growth rate or a tax rate, this occurs often. It would be ideal if we could
modify this cell once and have the new rate used by all of the formulae.

 



Using the F4 key to simplify dollar sign entry
The good news is that you are not required to input the dollar signs. Instead,
immediately after entering a reference, while the cell is still in edit mode,
hit the F4 key to switch the reference from a relative to an absolute
reference, which includes the dollar signs before the row and column. When
you hit F4 one again, the reference changes to a mixed reference with a
dollar sign before the row number.

Once you hit F4 again, the reference changes to a mixed reference with a
dollar symbol in front of the column letter. Pressing F4 again changes the
reference to a relative reference. Looking at the many reference possibilities
provided by the F4 key may help you pick the proper reference.

The following sequence demonstrates how the F4 key works when
inputting a formula. This example was included because it necessitates the
usage of two different forms of mixed references.

The key point is that you begin hitting F4 after inputting a cell reference but
before typing a mathematical operator:

1. Enter A6 type.

2. Press the F4 key before entering the asterisk to signify
multiplication. When you hit F4, the reference changes to =$A$6.

3. Press the F4 key once again. The reference is changed to A$6 in
order to fix the reference to row 6. This is still incorrect since
freezing the reference to row 6 will have no effect.

4. Press F4 one more. Excel just locks the column and changes the
reference to =$A6. This is the version of the reference you’re
looking for. The formula always refers back to column A when you



duplicate it across. As you replicate the formula, the row number in
this reference might vary to point to other rows.

5. To continue the calculation, insert an asterisk to indicate
multiplication and then use the mouse to click cell C5.

6. To accept the formula, press Enter.

7. Copying the formula from cell C6 to the range C6:G28
automatically multiplies the rate in column A by the number of
days in row 5. The calculation appropriately multiplies the ten-
dollar rate in column A9 by the twenty-four-hour value in cell E5.

 

Ways to enter formulas
In the preceding sections, you input a formula by entering it. In most cases,
you must begin a formula by entering the equal sign (or the plus sign);
following that, you have three options:

Enter the whole formula as explained in the preceding sections.

Use the mouse to touch cell references rather than typing the
operator keys.

Enter the operator keys, then use the arrow keys to go to the cells to
provide the cell references. This strategy is known as the arrow key
method in this book.

 

Enter formulas using the mouse method
If you’ve been using computers since 1993, you’ve probably used the
mouse technique to input formulae. This approach is simple, but it needs



you to switch your hand between the keyboard and the mouse multiple
times, as seen below:

1. Enter = or +.

2. Select cell B2.

3. Enter *.

4. Select cell F1.

5. Hit F4 to insert the dollar signs.

6. Enter your password. The cell pointer is normally moved to cell C3.

This approach involves just four keystrokes, but you must move your
mouse twice. Moving the mouse is the most time-consuming component of
inputting formulae, but if you are not a touch typist, this approach is faster
than typing the complete calculation.

 

Using the arrow keys to enter formulas
The arrow key approach is common among spreadsheet users who began
using Lotus 1-2-3 version 2.2. Learning this strategy is valuable since it is
really quick. Almost all formulas may be entered using the keys on the right
side of the keyboard. This is how it works:

1. In cell C2, use the numeric keypad if you have one to enter +. If
you don’t have a numeric keypad, use your keyboard’s equal sign.

 

2. Move the flashing cell boundary to cell B2 by using the left arrow
key. It is worth noting that the active cell, which has a green solid
border, is still cell C2. The flashing border functions as a second
cell pointer, allowing you to point to the right cell for the formula.



 

3. To accept cell B2 as the proper reference in the formula, use an
operator key (such as * or +), a parenthesis, or Enter. In this
instance, enter the character *.

 

4. Notice that the dashed cell pointer has vanished, and the attention
has returned to the original cell, C2.

 

5. For three times, press the right arrow key. The flashing cell
boundary progresses to D2, E2, and finally F2. The temporary
formula in the formula bar displays an erroneous formula with the
first two key strokes (+B2*D2 and +B2*E2).

 

6. Use the up arrow key to shift the flashing cell border to its proper
place, cell F1. The temporary formula in the formula bar has been
changed to +B2*F1.

 

7. To add dollar signs to the F1 reference, use the F4 key.

 

8. To accept the formula and maintain the cell cursor in cell C2, hit
Ctrl+Enter.

 

Entering one formula and splitting many results
In cell C5, a formula of =A2:A9 is entered. Excel dumps the results into
C5:C12. When you choose a cell in C5:C12, the formula is shown in the



formula bar, and a blue outline appears around the results range. Consider
the blue outline to be an indication that this single formula is returning all
the answers contained inside the outline.

Here’s a crucial distinction: The formula can only be found in one cell: C5.
When you pick C6, C7, or C12, the formula shows in a light gray font in the
formula bar. However, you can only alter the formula if you choose C5. It is
sufficient to use the formula =FORMULATEXT(C5). A
=FORMULATEXT(C6) formula will fail.

If A1:A9 is a table, and you add more rows to it, the results of this single
formula will automatically grow. Alternatively, if row 4 is removed, the
results will be reduced.

 

Referring to an entire array with the # operator

In Excel, the hash sign (#) represents a new operator called the Spilled
Range Operator. To refer to all the cells returned by the formula in the
reference, add a # after the reference.

A2 formulas, for example, yield the integers 2, 6, 10, 14, 18, and 22. If you
merely say A2, you are pointing to the number two in A2. However, if you
refer to A2#, you are referring to all six numerals. The result of
=SUM(A2#) is 72.

If the formula in A2 changes and begins yielding a smaller or bigger array,
the A2# reference will continue to link to all array results.

 

Use the Table tool to copy a formula



 

 

When you declare your current data set as a table, Excel automatically
transfers new formulae to the table’s remaining cells.

To create a table from a range, choose a cell in the data set and click
Ctrl+T. Excel’s IntelliSense algorithm is used to predict the table’s
edges. If the program’s prediction is right, click OK in the Create
Table dialog box.

Ctrl+T is one of four options for starting a table. On the Home tab,
choose Format as Table. From the Insert tab, choose the Table
icon.

 

More than a few changes occur when Excel identifies the range as a table:

The table is prepared using the standard formatting. (NB: This
might contain banded rows or columns, depending on your
preferences).

Drop-down menus for AutoFilter have been added to the headers.



Any formulae you input by using the mouse or arrow keys relate to
cells in the table by utilize the headers.

When you put a formula in the table, Excel automatically copies it down to
all the table’s rows.

 

Keyboard Shortcuts

If you type a lot, accessing instructions from the keyboard is quicker than
shifting your hand to the mouse. Many of the old Alt keyboard shortcuts
from Excel 2003 are still in use. All the old Ctrl shortcut keys still work.
Ctrl+C, for example, still copies a selection; Ctrl+X, cuts a selection; and
Ctrl+V, pastes a selection.

 

Using the shortcut keys
If you resolve to learn and use one new shortcut key each week, you will
rapidly become an Excel expert.

 

Using keyboard accelerators



The Excel keyboard accelerators’ objective is to allow you to access any
command by using just the keyboard. Many common actions had keyboard
accelerators in previous versions of Excel, while some did not. Excel now
strives to guarantee that every command can be accessed using the
keyboard.

Press and release the Alt key or a forward slash (/) to access the new
accelerators. Excel displays a KeyTip above each command. In addition,
numeric KeyTips are shown above each item in the Quick Access Toolbar.
To show or conceal the KeyTips, use the F10 key.

The KeyTips for the ribbon tabs can be memorized. In all Office apps,
pressing Alt+F brings up the File menu. In all Office apps, pressing Alt+H
brings up the Home tab. The keyboard shortcut Alt+Q places the cursor
within the Tell Me What You Want To Do box. Even if additional ribbon
tabs are displayed, the accelerator definitions for each tab stay unchanged.
The original KeyTip letters are retained when you activate a pivot table.

Unfortunately, the Quick Access Toolbar KeyTips change every time you
add or rearrange items on the Quick Access Toolbar. If you want to
remember those KeyTips, make sure you don’t add a new Quick Access
Toolbar icon at the start of the list.

 

Choosing icons from the ribbon
After pressing the Alt key, you will bring up the relevant tab by pressing
one of the KeyTip letters. (NB: Additionally, you will notice that each
symbol on the ribbon now includes a KeyTip).

 



When you choose a Ribbon tab, the KeyTips on the Quick Access Toolbar
vanish, allowing Microsoft to utilize the letters A–Z and digits 0–9.

Some instructions take two keystrokes on particularly crowded ribbon tabs,
like as A+C for Align Center in the Alignments group of the Home tab. It’s
worth noting that you don’t have to keep holding down the Alt key after
displaying the accelerators in the ToolTips.

AT for Align Top, AM for Align Middle, AB for Align Bottom, and AL for
Align Left seem to be useful shortcut keys. Other shortcut keys seem to be
allocated haphazardly. Some people think that using FN for the dialog box
launcher is a good idea since it opens the old Format dialog box and
proceeds to the Number tab. Others can be traced back in time.

Similarly, under the Home tab, pressing O brings up the Format drop-down
menu. However, since Microsoft no longer emphasizes the accelerator key
in the menu name, O will never make sense to a novice Excel user. Most
people are unaware of the esoteric, logical reason why 5 and 6 are utilized
for increase and decrease indent.

 

Selecting options from a gallery



Excel demonstrates the consequences of hitting Alt+H+J, which is equal to
choosing Home, Cell Styles. This displays a collection of cell styles. By
hitting N and M at the bottom of the gallery, you can access the New Cell
Style and Merge Styles commands. In the gallery, however, there are no
letters on the table style options.

 



Using drop-down menus to navigate
The font size in the drop-down menu is chosen if you press Alt+H+F+S,
which is comparable to picking Home, Font Size. You may either input a
font size or hit Enter, or you can activate the drop-down menu by using the
down-arrow key. Then, to go through the list, use the down arrow, up arrow,
Page Down, Page Up, Home, and End keys. When you have highlighted the
desired item, click Enter to choose it.

 

Backing up one level through a menu
Assume you hit Alt+H to get to the Home tab and then find you’re at the
incorrect one. You may return to the ToolTips for the main menu options by
using the Esc key. If you wish to entirely clear the ToolTips, hit Alt again.

 

Dealing with Keyboard Accelerator Confusion
You may be irritated if you wish to pick anything on the Home tab since
you can see the menu options but no ToolTips display for most tasks. The
main KeyTips appear to apply to menu items for icons at the top of the
ribbon. For instance, you might believe that the H KeyTip applies to Cut.
Even if you are already on the Home tab, you must hit the H key to compel
Excel to display the ToolTips for the Home tab’s individual menu items.

 

Using my favorite shortcut keys
A list of hundreds of shortcut keys might be daunting. You can’t possible
learn 238 new shortcut keys and start using them right now. The parts that



follow go through some of my favorite shortcuts. Every week, try to include
one new shortcut key into your Excel habit.

 

Quickly move between worksheets

The shortcut Ctrl+Page Down takes you to the next worksheet. Ctrl+Page
Up takes you back to the previous worksheet. Assume you have 12
spreadsheets labeled January, February, March,..., December. If you are
presently on the Jan worksheet, hold Ctrl and hit Page Down five times to
go to the Jun worksheet.

 

Using Ctrl+arrow to navigate to the bottom of a data set
If your data does not include any blank cells, use Ctrl+down arrow to
advance to the final row in the data set. To navigate to the first row of the
data set, use Ctrl+up arrow.

To select from the current cell to the bottom, hold down the Shift key. If
you have data in A2:J987654 and are in A2, you may select all the data
rows but omit the headers in row 1 by holding down Ctrl+Shift while
hitting the down arrow and then the right arrow.

 

Using Ctrl+* to select the current region
To choose the current range, use Ctrl+*. The current range is the whole
data set, extending from the current cell in all directions until Excel reaches
the boundary of the worksheet or a fully blank row and column. On a



desktop computer, hold down Ctrl and press the asterisk on the numeric
keypad.

 



Advancing to the next part of a selection
You just chose A2:J987654, yet you’re looking at the bottom-right corner of
your data. To move to the next corner of your data, press Ctrl+period.
Because you are in the bottom-right corner, you must press Ctrl+period
twice to move to the top-left corner. Despite the fact that this moves the
active cell, it does not undo your selection.

 

Using Shift+F10, open the right-click menu
Shift+F10 bring up the right-click menu. To navigate through the menu
options, use the up/down arrow keys, and the right arrow key to launch a
fly-out menu. When you’ve found the item you’re looking for, hit Enter to
select it.

 

 

 

Using Ctrl+5 to cross activities off your list

To apply a strikethrough to a cell, select it and press Ctrl+5.

 

Time stamp or date stamp using Ctrl+: or Ctrl+;

Here’s a simple method for remembering this shortcut. What is the current
time? It’s 11:21 a.m. here. In the time, there is a colon. To enter the current
time in the active cell, use Ctrl+colon.



Do you need the current date? The same keystroke, but without the Shift
key. The current time is entered by pressing Ctrl+semicolon.

It should be noted that this is not the same as using =NOW() or =TODAY()
(). These functions evolve with time. These shortcuts record the time or
date you pushed the key, and the value remains unchanged.

 

 

Repeating the last task with F4
Assume you just chose a cell and pressed the Home button, OK, Delete,
Delete Cells, Delete Entire Row. You must eliminate 24 additional rows
from your data collection at different points.

Select a cell in the next row to remove and hit F4, which repeats the same
instruction but on the current cell.

F4 selects a cell in the following row to remove. Without your needing to
hit Home, all 24 rows are removed before you realize it. Delete, Delete
Cells, Delete Row, OK 24 times

The F4 key is compatible with 92% of the commands you will use. Give it a
shot. (NB: You will enjoy it. When you try to use one of the unusual
commands that cannot be redone with F4, it will be obvious).

 

Using F4 to add dollar signs to a reference
That’s right—F4 is used by two of my favorites in a row. When you’re
typing a formula and need to convert A1 to $A$1, press F4 when the
insertion point is near A1. If you hit F4 again, just the row containing A$1



will be frozen. F4 once again to freeze the column containing $A1. To
return to A1, press once again.

 

Using a slicer to choose items
It’s a little strange, but you can now enter a slicer using shortcut keys. You
may then choose or deselect items in the slicer by using the new Multi-
Select icon. To access the slicer, use Ctrl+G to bring up the Go To dialog
box.

To access Go To Special, press S. To choose the first item on the worksheet,
type B for Objects and hit Enter. You may need to hit Tab to access the
slicer, but you can browse through it using the arrow keys. When you press
Enter or the spacebar on an item, it toggles. To quit the slicer, use Ctrl+G,
then enter a cell address, such as A1.

 

 



CHAPTER FIVE

How to use formulas to join text

When you need to join text, you use the ampersand (&) operator. The &
operator in Excel is known as the concatenation operator.

To improve the appearance of the output when using the & operator, it is
often necessary to include a space between the two items that are combined.
For example, if the cells contain the first and last names, you should leave a
space between them. To include a space between cells, use the & followed
by a space enclosed in quotes, as in &” “.

 

Joining text and a number



In many cases, the & operator can be used to join text with a number or a
date. Despite the fact that D2 is formatted to show only two decimal places,
the underlying answer has more decimal places. The extra decimal places
are shown by the regular concatenation formula in E2. To resolve the issue,
insert the TEXT() function around D2 in the formula. As the second
option, use quotes to provide any acceptable numeric formatting code. In
E6, the updated formula use TEXT(D6,”#,##0.00”).

When you attach text to a date or time, instead of the date, you see the serial
number that Excel saves behind the scenes. To format the date, use the
TEXT() function around it, as illustrated in column E7. In E7, the formula
is =”His birthday is “&TEXT (D7,”DDDD, MMMM D, YYYY”).

 

How to understand error messages in formulas
Don’t be disheartened if a formula produces an erroneous result. This
occurs to everyone eventually. The goal is to grasp the distinctions between
the different error numbers so that you can begin troubleshooting the issue.



When entering formulae, you may encounter several mistakes, such as
those stated below:

#VALUE!: This error indicates that you are attempting to do math
on non-numerical data. For instance, the formula =4+”apple”
yields a #VALUE! error. This issue also happens if you attempt to
input an array formula but do not use Ctrl+Shift+Enter.

 

#DIV/0!: This error occurs when a number is divided by zero, or
when the denominator of a fraction evaluates to zero.

 

#REF!: When a cell reference is invalid, this error occurs. This
mistake may arise, for example, if one of the cells mentioned in the
formula is removed. It may also happen if you copy and paste
another cell above a cell mentioned in this formula. You may also



see this error if you use Dynamic Data Exchange (DDE) algorithms
to connect to non-running external systems.

 

#N/A!: This error happens when a function or formula does not
have access to a value. #N/A! errors are most often caused by key
values not being discovered during lookup routines. They may be
caused by HLOOKUP, LOOKUP, MATCH, or VLOOKUP. They
may also occur when one of the parameters in an array formula is
not the same dimension as the other arguments, or when a function
omits one or more essential inputs. Surprisingly, when a #N/A!
error enters a range, all future computations that relate to the range
have a #N/A! value.

 

#NULL!: This error usually indicates that a formula’s two cell
references are separated by a space rather than a colon or comma.
The intersection operator is the space operator. If the two references
have no cells in common.

 

#SPILL!: This mistake was introduced in Office 365. If you apply
one of the new =A1:A100 formulae in cell C1 and some non-blank
cells emerge among the 100 cells required for the answer, the cell
containing the formula will display a #SPILL! error. Other reasons
of the #SPILL! error include the formula overflowing over the edge
of the page or the computer running out of memory.

 

#FIELD!: This is a new error in 2018 that indicates an issue with a
Linked Data Type. If the referred field is not accessible in a linked



data type, or if the formula references a cell that does not include a
linked data type, the error occurs.

 

#CALC: Your formula produces an empty array. The calculation
engine is unable to resolve the formula at this time, although the
syntax may be supported in the future. The Excel team intends to
push out a number of additional functions across numerous releases,
and the #CALC error is required if they want to roll out part of a
two-function solution.

 

######: This is not a mistake. Instead, it signifies that the result is
too large to show in the current column width, and you must expand
the column to view the full result. Although ###### often indicates
that the column is too narrow, it may also show if you subtract one
date or time from another and end up with a negative total. Unless
you use the 1904 Date System, Excel does not support negative
dates or times.

 

How to use date math



Dates are kept in Excel as the number of days since January 1, 1900. Excel,
for example, records the date February 17th, 2021 as 44244. The date is in
cell E1. Cell E2 has the formula =E1 and is prepared to display a number.

 

This useful approach allows you to do some basic arithmetic. Column D
contains the invoice’s payment conditions. By combining cells B2 and D2,
you may compute the due date.

What truly occurs in Excel’s computation engine is as follows:

1. The date in cell B2 is recorded as 43132.

2. Excel multiplies that number by ten to obtain the result 43142.

3. Excel converts this number to a date, yielding 2/11/2018.

4. However, if the cell holding the formula has the incorrect numeric
format, an irritating situation might ensue. It is vital to note that
dates in 2019–2021 vary from 43,466 to 44,561. So, if you
anticipate a date response from a formula and receive a number in
this range, the answer most likely has to be formatted as a date.

5. To apply a date format, go to the Home page and choose the Date
format from the Number drop-down box. The solution in column D
is now accurate.

6. In general, most formulae that relate to a date column are
represented as a date by default. The majority of formulae
containing Date category functions are expressed as dates. (One
vexing exception is the WORKDAY function.)



 

How to automatically format formula cells
The formatting standards for formula results seem to be inconsistent.
Assume you have $1.23 in cell A1. Except for cell A1, all of the cells in the
worksheet follow the general pattern.

If you type =A1+3 in another cell with general format, the result will
immediately inherit cell A1’s currency format.

When many cells are referenced in a formula, the resultant automated
format does not seem to follow a pattern. When you begin a formula with
an equal sign, the format is copied from either the first or last cell
mentioned. When you use a + sign, the format may originate from the
second, first, or last reference, or it may be a combination of two references.

If your formula will refer to numerous cells with differing formatting, begin
it with an equal sign. Refer to the cell with the desired cell format first, but
be aware that the resultant cell may need to be explicitly formatted.

 



Using the @ operator to specify implicit intersection
Excel used to allow implicit intersection by default. If you typed A2:A10
into any cell in rows 2 through 10, Excel would only return the cell where
the formula crossed.

To use Dynamic Arrays in Excel, use a formula like =$A$2:$A$10, which
will now spill and return the values from all nine cells. To compel Excel to
utilize implicit intersection, put a @ symbol before the cell reference. By
inserting a @ before the reference, just Chris from A4 appears in cell C4.
When you copy C4 to C8, the response “Chris” becomes “Gary” since C8
overlaps with the reference’s A8.

 

How to copy versus cutting a formula

Because the formula has no dollar signs, they are relative references. If you
copy cell C4 and paste it into cell G2, the formula adds the two integers to



the left of G2 properly. If you cut C4 and paste it to F6, the formula still
points to cells A4+B4.

Whereas cutting and copying are comparable in apps like Word, they are
extremely different in Excel. It is critical to grasp the difference between
cutting and copying a formula in Excel. When you clip a formula, it
remains to link to the original antecedents, regardless of where you paste it.

The references given in a formula follow a similar pattern. Cell C4’s
formula, for example, leads to A4 and B4. You can copy cell A4 and paste
it wherever without modifying the formula in C4. However, if you cut A4
and paste it somewhere else, the formula in C4 would be updated to reflect
the new position.

Sometimes a mix of a cut and a copy is required. The formulae must
continue to point to the original cells, but they must be copied to a new
location.

The most typical method is to convert the formulae to text, copy and paste
them, and then convert the text back to formulas.

Take the following steps:

1. Determine the range of formulae to be cut/copied.

2. To open the Replace dialog, use Ctrl+H.

3. Substitute = for each =.

4. Duplicate the cells.

5. Copy and paste to a new location.

6. Use Replace to replace each = with a =.

 



Troubleshooting formulas
It is tough to decipher worksheets that were created by others. When you
get a worksheet from a coworker, utilize the information in the sections
below to locate and evaluate the formulae.

 

Selecting all formulas
For a long time, Excel has allowed consumers to view all of the formulae in
a spreadsheet. Show Formulas mode is the mode that gives this capability.

To enter Show Formulas mode for a worksheet, go to the Formulas tab,
then the Formula Auditing group, and finally the Show Formulas icon.
Alternatively, you can enter this mode by using Ctrl+’ (the grave accent).
The grave accent is commonly located right below the Esc key, on the same
key as the tilde ().

Select the Show Formulae icon once again to conceal the formulas and
return to regular mode.

 

Highlighting all formula cells
These steps colorize all formula cells in the worksheet:

1. Make sure you only have one cell chosen.

2. Choose Home, Find & Select, and Formulas.

3. In the Home tab, click the Paint Bucket icon to apply a color to all
of the formula cells.

 



Changing a single formula to demonstrate direct precedents
It’s useful to know which cells are utilized to compute a formula. These
cells are referred to as cell precedents.

There might be several layers of antecedents in a cell. There are two direct
predecessors in a formula like =D5+D7: D5 and D7. All the direct
predecessors of D5 and D7, on the other hand, are second-level antecedents
of the original formula.

If you want to visually examine a cell’s immediate predecessors, perform
these steps:

1. Choose a cell with a formula.

2. Press F2 to enter Edit mode in the cell. In this mode, each formula
reference is highlighted in a distinct color.

3. Examine the formula visually to confirm that it is valid.

 

Using auditing arrows in formulas
If you have a difficult formula, you should look for direct precedents first,
followed by second- or third-level precedents.

You can instruct Excel to create arrows from the current cells to all cells
that comprise the precedents for the current cell. To have Excel draw
arrows, do the following:

 

1. On the Formulas tab, choose Trace Precedents from the Formula
Auditing category. Excel creates arrows connecting the current cell
to all of the cells that are directly referenced in the calculation.



(NB: This means that at least one of the predecessors for this cell
may be found on another worksheet).

 

2. Click Trace Precedents once again. Excel creates arrows
connecting the precedent cells to their antecedents. These are the
original cell’s second-level predecessors. Continue to click Trace
Precedents to view more levels. Almost every cell on the
spreadsheet is an antecedent of cell D32 in this situation.

 

3. In the Formula Auditing group, click the Remove Arrows button
to remove the arrows.

 

 



CHAPTER SIX

About Worksheets and Workbooks
 

How to connect two worksheets

Despite the fact that Excel has 17 billion cells on each worksheet, it is
extremely typical to split any model over many worksheets. You might have
one worksheet for each month of the year or one worksheet for each
functional area of a firm.



Because various departments may be in charge of distinct functional areas,
it seems sensible to segregate them into separate spreadsheets. However,
you will eventually want to combine information from the many worksheets
into a single summary worksheet.

 

To view two worksheets from the same workbook side by side, follow these
steps:

1. Open the first spreadsheet you want to look at.

2. Select New Window from the View menu. Nothing seems to have
occurred if your workbook is in full-screen mode. However, when
you check in the title bar, you will see that your workbook title has
“ - 2” following it.

3. On the View tab, click Arrange All, and then choose Vertical or
Horizontal. Check the Windows of Active Workbook box.

4. In the second window, select the second worksheet tab to view.
(NB: You may now see both worksheets from the same workbook
at the same time. Each window in Excel now has its own ribbon
and status bar).

Note: Click the Close Window symbol, which is the X in the top-right
corner of the second window, to return to a single window.

There are four options for achieving this goal:

In cell B5, enter a formula, such as =Revenue!F6.

Using the mouse, construct the formula. For example, enter an equal
sign in cell B5 of the Summary sheet and then click on cell E6 of
the Revenue sheet with the mouse. Then hit the Enter key.



Right-click and drag cells F6:G6 from the Revenue tab to the
appropriate spot on the Summary tab, then choose Link Here.

Make a copy of cells F6–G6 on the Revenue tab. Copy and paste to
cells B5:C5, then choose Link Here from the Paste Options fly-out
menu.

 

Creating links to unsaved workbooks
You can create a formula that points to an un-saved source worksheet. This
formula might link to Book 1, Book 3, or something similar. When you try
to save the target workbook, Excel displays the Save filename> With
References To Unsaved Documents? dialog box. In general, cancel the
save, go to the unsaved source workbook, and then choose File, Save As to
save the file with a permanent name. (NB: From there, you can then
return to save the linked worksheet).

 

Creating links between worksheets
There are many simple methods for connecting worksheets or even
workbooks. Instead of inputting the same value many times, you may enter
it once and have it roll over to other worksheets and workbooks.

 

Using the Paste Options menu to create links
To create a link using the new Paste Options fly-out menu, follow these
steps:

1. Select the cells containing the figures you wish to duplicate.



2. To duplicate those cells, use Ctrl+C.

3. Right-click the cell where you want the link to appear. Paste Link is
the sixth icon in the Paste Options menu that appears.

4. From the option that displays, choose Paste Link. On the Summary
worksheet, Excel will put formulae in cells B5:C5.

 

Using the right-drag menu to create links
There is a simpler technique to build connections if you are skilled with the
mouse. This is especially true if you put the two spreadsheets side by side.

The Alternate Drag-And-Drop menu is used in this manner. This
incredible menu, which has been hidden in Excel for numerous editions,
provides a quick method to copy cells, connect cells, transform formulae to
values, and much more.

When you right-click the boundary of a selection, drag it to a different
position, and then release the mouse button, the Alternate Drag-and-Drop
option displays.

Hover around the selected rectangle’s edge until you see the four-headed
arrow. Right-click and start dragging to the other window.

When you’ve arrived at your new destination, let go of the right mouse
button and choose Link Here. In the target location, Excel creates a formula
with the correct syntax to connect to the source cells. Because the
worksheet name includes a space, Excel wraps it in apostrophes: =’Expense
Summary’! F3.

 



Building a formula by typing
You can always create the connections manually by inputting the formula.
Because you must grasp a variety of syntactic rules, this is the least
common way. Remember that the syntax requirements differ based on
whether the worksheet name includes a space, if the connection is external,
and whether the connected workbook is open or closed.

The syntactic rules are as follows:

Use =SheetName!CellAddress for an internal connection when the
worksheet name does not include a space or special characters.
=Result!B3 is an example.

Add apostrophes around the workbook and sheet names if the
worksheet name includes a space or certain special characters.
=’Result Sheet’ is an example! B3.

For an external link, the workbook name is enclosed in square
brackets and appears before the sheet name. =
[LinkToMe.xlsm]Sheet1!B3 is an example.

If the workbook or sheet name includes a space, use an apostrophe
before and after the opening square bracket. =’[My File.xls]Income
Statement’ is an example! B3.

When Excel refers to a file, such as [RegionTotals.xlsm], it is safe
to presume that the file is open at the time. (NB: When you shut the
connected file, Excel adjusts the connecting workbook’s formula
to include the full pathname. =SUM(’C:[Region
Totals.xlsm]Quota’!$B$2:$E$2) is an example).

 



Dealing with missing linked workbooks

If you get a linking workbook via email and do not have access to the
connected workbooks, Excel notifies you that the workbook includes links
that cannot be modified at this time. In this situation, you should press the
Continue button in the dialog box.

 

Opening workbooks with links to closed workbooks
Assume you’ve saved and closed the connecting worksheet. You make
changes to the numbers in the attached worksheet. You save and exit from
the connected worksheet. When you access the linked workbook later,
Excel prompts you to update the connections to the other worksheet.
Allowing the workbooks to update is OK if you generated both workbooks
and hold custody of both workbooks.

 



Updating links when a workbook is renamed or moved
It is usual for the source workbook to be renamed or relocated. If you
connect to CommissionRates2025.xlsx and a new commission plan for
2026 is produced, someone will use File, Save As to create a new
CommissionRates2026.xlsx workbook. In this case, all workbooks that
reference CommissionRates2025.xlsx would need to be modified to
reference CommissionRates2026.xlsx. As you may expect, this procedure
occurs just once a year.

In a perfect world, you would open CommissionRates2025.xlsx and any
workbooks that are linked to it. With all workbooks open, open
CommissionRates2025.xlsx and choose File, Save As. Change the name of
the spreadsheet to CommissionRates2026.xlsx. All open workbook links
that previously pointed to CommissionRates2025.xlsx will now point to
CommissionRates2026.xlsx.

 

 



However, the person who maintains the Commission Rates workbook is in
another office, and they often make changes without remembering that
other workbooks are connected to his workbook.

 

Select Data > Edit Links to open the Edit Links dialog box and modify
all links in a worksheet to go to a new workbook. Then, click the Change
Source button to notify Excel that the associated workbook has been
renamed or relocated. Alternatively, you may need to use the Break Link
option to reset all connected formulae to their default settings.

 

Using the Trust Center’s Links tab
Excel’s default security settings thwart your efforts to retrieve data from
closed workbooks. Consider the following situation, which makes use of
two workbooks called Workbook A and Workbook B:

1. Create a connection between Workbook A and Workbook B.

2. Save and exit Workbook A.

3. Make changes to Workbook B, then save and shut it.

4. Next, open Workbook B.

5. Launch Workbook A.

In this situation, the updated values in Workbook B are immediately
transferred to Workbook A.

When you activate the content for the first time, Excel designates the
document as trustworthy. The next time you access the worksheet, Excel
shows a separate warning regarding connections to potentially dangerous
external sources.



 

 



CHAPTER SEVEN

How to work with functions
To effectively utilize functions in a spreadsheet, you must adhere to the
function syntax. Keep in mind that every formula that uses a function must
begin with an equal sign. You must include the function name, an opening
parenthesis, function parameters (separated by commas), and a closing
parenthesis.

A function’s general syntax is as follows:

=FunctionName(Argument1,Argument2,Argument3)

 

Parentheses are required for all functions, even those that do not need
arguments. These functions, for example, nevertheless need the use of
parentheses:

=NOW()

=DATE()

=TODAY()

=PI()

The parameters to a function should be entered in the order given in this
book or in Excel Help. For example, the PMT() function wants the interest
rate to come first, followed by the number of periods, and finally the current
value. If you input the parameters in the wrong sequence, Excel will gladly
generate the incorrect result.



You can input parameters as integers or cell references in many
circumstances. For example, all of the following formulae are correct:

=SUM(1,2,3^2,4/5,6*7)

=SUM

(A1:A9,C1,D2,Sheet2!E3:M10)

=SUM(A1:A9,100,200,B3*5)

 

Errors may be returned by Excel functions. This most often occurs when
one of the parameters provided to the function is beyond the range of what
the function expects. If you get a #NUM!, #VALUE!, or #N/A error, seek
up the function in Excel Help. The Remarks section normally specifies
which issues may result in each sort of mistake.

 

Formulas tab in Excel

 

The Formulas tab in Excel is one place to look for functions. Insert
Function, AutoSum, Recently Used, Financial, Logical, Text, Date & Time,



Lookup & Reference, Math & Trig, and More Functions are the icons
available on this tab. When you select the More Functions button, a drop-
down menu with six more function categories displays, including
Statistical, Engineering, Cube, Information, Compatibility, and Web.

The Formulas tab is intended to make it easy to locate the appropriate
function. When you click an icon on the ribbon, an alphabetical list of the
functions in that group shows. When you move your cursor over a function
in the list, Excel shows an explanation of what it does.

 

Identifying the required function
The Formulas tab’s intrinsic difficulty is that you often have to guess where
your desired function could be lurking. Excel’s function categories have
been in place for almost a decade, and functionalities are sometimes hidden
in unexpected locations.

The SUM() function, for example, is a Math & Trig function. This makes
logical since number addition is plainly a mathematical procedure. The
AVERAGE() function, on the other hand, is not present under the Math &
Trig icon. (It may be found under More Functions, Statistical.) The
COUNT() function may be used for math, reference, or information,
however it is located under More Functions, Statistical.

Microsoft has made it tough to discover certain functions by categorizing
the list of functions.

 

Using the Tab key to perform AutoComplete operations



Formula AutoComplete is a function in Excel. You may recall a portion of
the function name but not the whole name. If you write =LOOK, Excel will
suggest LOOKUP, HLOOKUP, VLOOKUP, and XLOOKUP. Rather of
attempting to determine which category on the Formulas tab includes your
function, just begin typing =LOOK into a cell. Excel provides a pop-up
window with all the functions that include the word LOOK. Since Excel
2016, this feature has undergone changes. Previously, entering =LOO
would not have resulted in XLOOKUP, VLOOKUP, or HLOOKUP since
AutoComplete only matched words from the beginning.

You can also accept a function name from the list by double-clicking it or
by selecting the name and pressing Tab.

 

Using the Insert function dialog box to find functions



On the Formula tab of the ribbon, a huge Insert Function icon displays. At
the bottom of each function category, this instruction is repeated. These 14
new Insert Function entry points were introduced in Excel 2007, although it
is simpler to utilize the fx icon to the left of the formula bar.

To find the function, use the Search For A Function box. If you entered
loan payment and then clicked Go, Excel would propose PMT (the right
function) as well as PPMT, ISPMT, RATE, and other options.

When you choose a function in the Insert Function dialog box, the dialog
box shows the function’s syntax as well as a one-sentence explanation. If
you want further information, click the Help On This Function hyperlink in
the lower-left corner of the Insert Function dialog box.



 

How to use AutoSum
Microsoft recognizes that the SUM() function is the most often used. Excel
gives one-click access to the AutoSum tool since it is so popular.

The AutoSum symbol is represented by the huge Greek letter sigma,
which is the second icon on the Formulas tab or a tiny icon on the right side
of the Home tab. You can use AutoSum by clicking this icon, or by using



the drop-down menu at the bottom of the icon to obtain AutoSum versions
of Average, Count Numbers, Max, and Min.

When you click the AutoSum button, Excel attempts to add up the values
above and to the left of the current cell. When you click the AutoSum
button, Excel generally guesses which cells you are attempting to sum.
Excel fills in the SUM() calculation for you. You should double-check
Excel’s guess to ensure that it picked the right range to total.

 

AutoSum’s potential flaws
Although you should always double-check the range suggested by the
AutoSum function, you should be extremely cautious in specific
circumstances.  If Excel suggests the incorrect range for a total, use your
mouse to highlight the right range before clicking Enter.

In an AutoSum range, Excel avoids incorporating additional SUM()
operations. If a range includes an SUM() function that refers to other cells,
Excel terminates the program shortly before the SUM() function. This issue
occurs only when the SUM() method refers to additional cells. AutoSum
would include the cell if it contained =7000+1878, =H3+H4, or
=SUM(7000,1878).

Excel likes to add a total to a column of numbers rather than a row of
numbers. Excel properly predicts that you want to total B2:E2 if you
position the cell cursor in cell F2 and select AutoSum. Cell F3 is fully
functional. When you reach to cell F4, though, Excel gives you an option.
F4 has two numerals above it and four digits to its left. Excel attempts to
sum the two values right above since there are two numbers directly above.



This issue appears in the third row of the data set and progresses to the
bottom.

 

AutoSum has certain unique features

Users can use an awesome technique with AutoSum. Excel performs a far
better job of guessing what to sum if you pick a range of cells before
selecting the AutoSum button.

Before pressing the AutoSum button, you could pick B11:E11, and Excel
would know to total each column. However, be cautious since Excel does
not provide a preview of its prediction before to inputting the calculation.
Always double-check a formula after using AutoSum to ensure that the
right range was chosen.

If your selection includes both blank and non-blank cells, Excel only
applies the AutoSum to the blank cells. Excel appropriately fills up totals
for all rows and columns once you click the AutoSum button.

 

Can you AutoSum from the top of a numeric column?

There is no trick to getting the AutoSum to add the values underneath the
active cell. If you must do this repeatedly, however, take these steps:

1. Click on the empty cell above a column of numbers.

2. To begin the AutoSum, press Alt+=.

3. If Excel used a cell reference as the starting point for the
calculation, use the Delete key.



4. To navigate to the first number in the range, press the down arrow
once.

5. Select the end of the range by pressing Ctrl+Shift+Down Arrow.

6. Enter your password.

 

Making use of AutoAverage or AutoCount
The AutoSum button has a drop-down menu arrow with the options
Average, Count, Max, and Min. If you find yourself often utilizing the
options in this drop-down menu, you may add an AutoAverage, AutoCount,
and so on icon to the Quick Access Toolbar.

Select AutoSum from the drop-down option. Right-click Average and
choose Add to Quick Access Toolbar to get one-click access to an icon
that functions similarly to AutoSum but employs the AVERAGE
calculation instead.

 

Examples of date and time function



Using NOW and TODAY to compute the current date and time or current
date and time and date and date and date and date and date and date and
date and date and date and date and date

There are many keyboard shortcuts for inputting the date and time. Ctrl+;
enters the current date into a cell. Ctrl+: enters the current time into a cell.
However, both of these hotkeys generate a static value, which means that
the date or time represents the moment you entered the hotkey and never
changes in the future.

For computing the current date, Excel has two functions: NOW and
TODAY. These functions are useful for calculating the number of days till
a deadline or the late status of an open receivable.

Note: It would be ideal if NOW() functioned in Excel like a real-time
clock, continually updating. However, the result is computed every time
the file is opened, every time the F9 key is used, and every time an input is
made elsewhere in the worksheet.

 

Syntax:

=NOW()

=TODAY()

The serial number of the current date and time is returned by NOW.
TODAY yields the current date’s serial number. The TODAY function
returns the current date without a time. The current date and time are
returned by the NOW function.

Both of these methods may be used to show the current date, but there is a
crucial difference to be noted when using the functions to make



computations.

Row 8 computes the number of days remaining before a deadline. Although
most people believe that tomorrow is one day away, the calculation in A8
indicates that the deadline is 83.6924 days away. This might be misleading.
If you want to utilize the result of NOW or TODAY in a date calculation,
use TODAY to avoid Excel reporting fractional days. The formula in A8 is
=A7-A3, expressed as a number rather than a date.

To separate a date/time, use YEAR, MONTH, DAY, HOUR, MINUTE, and
SECOND.

To extract a specific component of a date, Excel has six functions: YEAR,
MONTH, DAY, HOUR, MINUTE, and SECOND.

Functions in A3 through A8 decompose the date into its constituent parts:

The year component of the date is returned as a four-digit year via
=YEAR(date).

=MONTH(date) yields the month number, ranging from 1 to 12.

=DAY(date) yields the day of the month, ranging from 1 to 31.

=HOUR(date) provides the current hour, ranging from 0 to 23.

=MINUTE(date) yields the minute between 0 and 59.

=SECOND(date) gives the second value between 0 and 59.

Date must have a legitimate Excel serial number in each instance. The date
serial number cell may be formatted as a date or as a number.

 

 

Using DATE to compute a date based on the year, month, and day



The DATE function is one of Excel’s most outstanding features. Microsoft’s
version of this function is fantastic, enabling you to do incredible date
computations.

Syntax: =DATE(year,month,day)

The DATE function returns the serial number that corresponds to a certain
date. This function accepts the following parameters:

 

Year: This argument may range between one and four numbers. If
the year is between 0 and 1899 (inclusive), Excel multiplies the
value by 1900 to determine the year. =DATE(100,1,2), for example,
yields January 2, 2000 (1900+100). Excel uses the value between
1900 and 9999 (inclusive) as the year. =DATE(2000,1,2), for
example, yields January 2, 2000. If the year is less than 0 or higher
than 10,000, Excel gives a #NUM! error.

 

Month: This is a digit that represents the month of the year. If
month is larger than 12, month adds that many months to the first
month of the chosen year. =DATE(1998,14,2), for example,
provides the serial number corresponding to February 2, 1999. If it
is 0, it indicates the prior year’s December. If the value is negative,
it returns previous months; nonetheless, –1 indicates November, –2
October, and so on.

 

Day: This is a number that represents the month’s day. If the
number of days in the month is larger than the number of days
indicated, it adds that number of days to the first day of the month.



=DATE(2018,1,35), for example, yields the serial number
corresponding to February 4, 2018. The preceding month’s final day
is represented as zero. Negative numbers, like months, return days
early. =DATE(2018,3,5) yields March 5, 2018, as an example.

When one or more of the year, month, or day values are computed in the
DATE function, the true power happens. Following are some examples:

If cell A2 has an invoice date and you wish to compute the day one
month later, use =DATE(Year(A2),Month(A2)+1,Day(A2)).

To determine the start of the month, use
=DATE(Year(A2),Month(A2),1).

You use =DATE(Year(A2),Month(A2)+1,1)–1 or
=DATE(YEAR(A2),MONTH(A2)+1,0) to compute the end of the
month.

Excel’s DATE function is incredible since it allows it to precisely cope with
incorrect dates. It is not an issue if your calculations for Month result in a
value greater than 12. For example, if you ask Excel to compute
=DATE(2025,16,45), Excel will consider April 2026 to be the 16th month
of 2025. Excel advances to May 15, 2026 to discover the 45th day of April
2026.

 

Using TIME to calculate a time
The TIME function and the DATE function are quite similar. It generates
a time serial number based on an hour, minute, and second.

 

Syntax: =TIME(hour,minute,second)



The TIME function returns a decimal value corresponding to a certain time.
TIME returns a decimal number ranging from 0 to 0. 999988425925926,
reflecting the times from 0:00:00 (12:00:00 a.m.) to 23:59:59. (11:59:59
p.m.). This function accepts the following parameters:

Hour: This is a number ranging from 0 to 23 that represents the
hour.

Minute: This is a number ranging from 0 to 59 that represents the
minute.

Second: This is a number ranging from 0 to 59 that represents the
second.

Excel, like the DATE function, can handle instances when the minute or
second parameter totals more than 60. =TIME(12,72,120), for example,
equals 1:14 p.m.

 

Using DATEVALUE to convert text dates to actual dates
It’s all too simple to wind up with a spreadsheet full with text dates. This is
sometimes caused by importing data from another system. It may also be
caused by someone not knowing how dates operate.

If your dates come in a variety of forms, you may use the DATEVALUE
function to convert them to serial numbers, which can then be displayed as
dates.

 

Syntax: =DATEVALUE(date text)

The serial number of the date represented by date text is returned by the
DATEVALUE function. DATEVALUE is used to convert a text-based date



to a serial number. The date text input contains text that represents a date in
Excel date format. “3/5/2018” and “05-Mar-2018,” for example, are text
strings inside quote marks that denote dates.

Using Excel for Windows’ default date system, date text must reflect a date
between January 1, 1900, and December 31, 9999. DATEVALUE yields a
#VALUE! If date text is outside of this range, an error is returned.
DATEVALUE utilizes the current year from your computer’s built-in clock
if the year element of date text is absent. Date text’s time information is
disregarded.

 

In this case, Excel should have been clever enough to format the resultant
cells into dates automatically. The cells are represented as numeric by
default. As a result, many people feel that DATEVALUE does not function.
To accomplish the desired outcome, you must use a date format.

 

Note: Text dates must be used using the DATEVALUE function. If you
have a column of values, some of which are text and some of which are
genuine dates, using DATEVALUE on the actual dates results in a
#VALUE error. =IF(ISNUMBER(A1),A1,DATEVALUE(A1)) might be
used. Consider the =DAYS(end,start) function, which may deal with text
or actual dates.

There are a few text instances that DATEVALUE does not recognize. When
there is no space following the comma, this is a frequent example. “January
21,2011,” for example, gives an error. To overcome this issue, use
SUBSTITUTE to convert a comma to a comma space:
=DATEVALUE(SUBSTITUTE(A2,”,”,”, “)).



 

Using TIMEVALUE to convert text times to actual times
It is quite simple to wind up with a column of text values that resemble
times. You may use the TIMEVALUE function to convert them to actual
times in the same way that you do with DATEVALUE.

 

Syntax: =TIMEVALUE(time text)

TIMEVALUE returns the decimal value representing the time provided by a
text string. The decimal number is a value between 0 and
0.999988425925926 that represents the times from 0:00:00 (12:00:00 a.m.)
to 23:59:59. (11:59:59 p.m.). The time text parameter is a text string that
represents a time in any of Microsoft Excel’s time formats. For example,
“6:45 PM” and “18:45” are time-related text strings enclosed in quote
marks. Date data in time text is ignored.

The TIMEVALUE function is difficult to use since it is simple to input
incorrect formats. Excel, on the other hand, considers this as 45 hours and
30 minutes. This misunderstanding renders TIMEVALUE almost worthless
for a column of cells containing text representations of minutes and
seconds.

 

TIMEVALUE is unable to identify a few pieces of text. When there is no
space before the AM or PM, this is a frequent case. “11:00PM,” for
example, produces an error. To remedy this specific issue, use
SUBSTITUTE to replace “PM” to “PM” and “AM” to “AM.” This is a
complicated formula:



=SUBSTITUTE((A2,”PM”,” PM”),”AM”,” AM”)*1

The *1 at the end ensures that it is numeric. Because the SUBSTITUTE
method produces a string, the result should be represented as time. This
function is applicable to time formats with or without a space before the A
or P!

Regrettably, Excel does not format the output of this function as a time.
Column B displays the result as it appears in Excel. Column C displays the
same result after applying a time format.

 

Using WEEKDAY to organize dates by weekday
If folks could simply agree on how to number the days, the WEEKDAY
function would be less scary. Just for Monday, this one function may
provide eight distinct outcomes.

 

Syntax: =WEEKDAY(serial number,return type)

The WEEKDAY function returns the weekday that corresponds to a given
date. By default, the day is specified as an integer ranging from 1 (Sunday)
to 7 (Saturday). This function accepts the following parameters:

Serial number is a sequential number that reflects the date you’re
looking for. Dates may be provided as text strings enclosed in
quotation quotes (for example, “1/30/2018”, “2018/01/30”), serial
numbers (for example, 43130, which represents January 30, 2018),
or as the outputs of other formulae or functions (for example,
DATEVALUE(”1/30/2018”)).



Return type is a numeric value that specifies the type of return
value.

If return type is 1 or omitted, WEEKDAY behaves similarly to a
wall calendar. Calendars are often printed with Sunday on the left
and Saturday on the right. WEEKDAY’s default version numbers
these columns from 1 to 7.

If return type is 2, you’re utilizing the biblical WEEKDAY. Sunday
is the seventh day of the week according to the Bible. Working
backwards, Monday must be at the top of the list.

You are using the accounting version of WEEKDAY if return type
is 3. In this version, Monday has a value of 0, Tuesday has a value
of 1, and so on. This version makes it extremely simple to organize
data by week. If cell A2 includes a date, A2-WEEKDAY(A2,3)
changes the date to the week’s first day, Monday.

In Excel, return types 11 through 17 were included. 11 will be back
as 1 on Monday and 7 on Sunday (the same as using 2). 12 returns
as 1 on Tuesday, 13 as 1 on Wednesday, and so on, up to 17 as 1 on
Sunday.

 

Getting help with Excel functions
Each Excel function offers three degrees of assistance:

ToolTip for On-Grid

The dialog box Function Arguments

Excel help

Note: If you enter =FunctionName(in a cell, you may access the Function
Arguments dialog box by pressing Ctrl+A after the opening parenthesis.



For example, enter =XLOOKUP (followed by Ctrl+A) or =REDUCE
(followed by Ctrl+A).

The parts that follow go through these different degrees of assistance.
However, you will undoubtedly find the Function Arguments dialog box to
be one of the most useful methods to get assistance.

 

Using ToolTips on the Grid
You can enter an equal sign, a function name, and the opening parenthesis
in any cell. Excel gives a ToolTip with the anticipated parameters. This
ToolTip is often sufficient to take you through the function.

The ToolTip is sufficient to remind me that the rate comes first, then the
number of periods, and finally the principal amount or present value. Any
function parameters shown in square brackets are optional; for example,
you may not need to input anything for fv or type.

The next parameter in the ToolTip appears in boldface as you input each
comma in the function. You’ll always know which debate you’re joining
this way.

 

Note: By the way, you can move the formula ToolTip to a different spot on
the worksheet by clicking it. If the ToolTip is covering cells that you need
to click while developing the function, this might be handy.

(NB: Excel provides Help for that function when you click the function
name in the ToolTip).

 



Using the Dialog Box for Function Arguments

Excel shows the Function Arguments dialog box when you access a
function using the Function Wizard or a drop-down menu. This dialog box
is one of Excel’s greatest features. If you’ve already begun typing the
function and the beginning parenthesis, hitting Ctrl+A or selecting the fx
icon to the left of the formula bar brings up the Function Arguments dialog
box.

 

The Function Arguments dialog box has many components:

A one-sentence explanation of the function shows in the dialog
box’s center.



As you tab into the text field for each argument, the dialog box
displays the argument’s description. This explanation will help you
understand what Excel is looking for. For example, Excel tells you
in the dialog box that the interest rate must be split by four for
quarterly payments. This serves as a reminder to divide the rate in
cell B3 by 12 for monthly payments.

A reference button is located to the right of each parameter in the
dialog box. You may close the dialog box by clicking this button,
allowing you to point to the cells for that argument.

To the right of each text box is a label that displays the outcome of
the argument’s input.

Any arguments in italics must be included. Arguments that are not
in bold are optional.

After you add the needed parameters, the dialog box displays the
formula’s tentative result. This is located on the right side, directly
below the last argument text field. It reappears in the lower-left
corner, immediately above the Help With This Function link.

In the lower-left corner of the dialog box, a Help On This Function
hyperlink to the Help subject for the function displays.

 

Using Excel Help
The Excel Help sections for the functions are quite detailed. The following
parts are included in the Help subject for each function:

The syntax for the function shows at the top of the subject. This
offers a more detailed explanation of each function than the one in
the Function Arguments dialog box.



The Remarks section assists you in troubleshooting any issues with
the function. It goes through precise restrictions for each input and
defines the significance of each conceivable error that the function
might return.

Each function has an example section that includes an integrated
Excel Web App worksheet. To download the example to your PC,
click the XL symbol in the sample’s footer.

The See Also section at the bottom of a Help subject allows you to
learn about related functions. See Also’s logical groupings are far
more useful than the Formulas tab’s category groupings.

 

How to use math functions
A formula to add a column of numbers is the most popular in Excel. Excel,
in addition to SUM, provides a number of mathematical functions.

 

Adding numbers using SUM
By far the most widely used function in Excel is the SUM function. This
function can combine numbers from one or more data sets.

 

Syntax: =SUM(number1,number2,...)

SUM sums all of the numbers in a range of cells. The parameters number1,
number2,... range from 1 to 255 and represent the total value or sum of the
arguments.



=SUM is a common application of this function (B4:B12). It is also
possible to use the operator =SUM (1,2,3). In the latter case, no more than
255 separate values may be specified. You may define up to 255 ranges in
the previous example, each of which can contain hundreds or millions of
cells.

It’s unlikely that you’ll need more than 255 parameters in this function, but
if you do, group them in parenthesis. =SUM((A10,A12),(A14,A16)) would,
for example, count as just two of the 255 permissible parameters.

When a text value that seems to be a number is included in a range, the text
value is not included in the total result. Surprisingly, if you supply the text
value directly as a parameter in the function, Excel includes it in the output.
For example, =SUM(1,2,3,4) equals 6, whereas =SUM(1,2,3,4) equals 5.
(D4:D6).

The comma is considered a union operator. Excel detects the cells that lie in
the intersection of the specified ranges if the comma is replaced with a
space. In cell E17, the formula =SUM(F13:H14 G12:G15) sums up the two
cells that are shared by both ranges.

If one cell in a referenced range has an error, the SUM function returns an
error. Use the AGGREGATE function to add numbers while disregarding
incorrect cells.

It is possible to develop a spearing formula. This formula adds the same cell
from many spreadsheets. =SUM(Jan:Dec!B20), for example, adds cell B20
on all 12 sheets between January and December. If the sheet names include
spaces or other nonalphabetic characters, use apostrophes to surround them:
=SUM(’Jan 2025:Dec 2025’!B20).

 



Using AGGREGATE to disregard incorrect cells or filtered

rows
The AGGREGATE function, which was added in Excel 2010, allows you to
execute 17 operations on a range of data while selecting disregarding
erroneous cells or rows masked by a filter.

 

Syntax: =AGGREGATE(func num, options, array, [k])

The function’s most intriguing feature is the options parameter. You have
the option of ignoring any, all, or none of the following categories:

Error codes

Hidden rows

Additional SUBTOTAL and AGGREGATE functionalities

Similar to the SUBTOTAL function, the option to disregard filtered rows
and other AGGREGATE functions is available. AGGREGATE’s ability to
disregard incorrect numbers answers a frequent Excel issue. A single #N/A
error cell in a range causes most Excel functions to output a #N/A error.
AGGREGATE’s settings allow you to disregard any error cells in the range.

The options argument specifies which values should be disregarded. This is
a simple binary system, as seen below:

To disregard other subtotals, add 0. Add 4 to include subtotals.

To disregard concealed rows, multiply by 1.

To disregard incorrect values, multiply by 2.

As a result, you give 3 (0+1+2) as the options parameter to
disregard additional subtotals, hidden rows, and error values.



You provide 5 (1+4) as the option to disregard error values but
include other SUBTOTAL values.

 

 

Choosing between COUNT and COUNTA
The key to choose between COUNT and COUNTA is to examine the data
to be counted.

In this scenario, COUNTA would be used to get an exact count. Dates are
shown in Column C. (which are treated as numeric). COUNT or COUNTA
delivers the proper value in column C. Column D contains both text and
numeric items. COUNTA may be used to count how many individuals took
the exam. Tally is used to count how many persons got a numerical score.

 

Rounding numbers

A number of functions are available, including ROUND, ROUNDDOWN,
ROUNDUP, INT, TRUNC, FLOOR, FLOOR.

MATH, EVEN, ODD, and MROUND—these functions round or eliminate
decimals from a result. ROUND is the most commonly used function.

ROUND(number, num digits) returns the rounded number. Use 0 as
the second parameter to round to the closest dollar. Use 2 as the
second parameter to round to the closest penny. Use –3 as the third
argument to round to the closest thousand dollars. Excel will round
away from zero if the digit after the final significant digit is
precisely 5. =ROUND(4.5,0), for example, will round to 5 and
=ROUND(-4.5,0) will round to –5.



 

ROUNDUP(number, num digits) never rounds to zero. Although
this normally increases the number, it is rare for negative integers to
behave this way. =ROUNDUP(-1.1,0) reduces the value from zero
to –2. If you want the result to be rounded to –1, use
TRUNC(number).

 

ROUNDDOWN(number, num digits) always rounds to the nearest
integer. Although this makes sense for positive numbers, it may not
make sense for negative numbers. =ROUNDDOWN(-3.1,0) rounds
to zero and yields –3. If you expect this to return –4, use
=INT(-3.1).

 

MROUND(number, multiple) returns the closest multiple. To round
to the closest 5 or 25, use this function. =MROUND(115,25) returns
125. There are a few unique variations. For the uncommon
condition in which things are packed two to a case,
=EVEN(number) always rounds up to an even number.
=ODD(number) returns an odd integer.

 

Examples of database functions
If you were a data analyst in the 1980s or early 1990s, you were probably
intrigued with database functions. When individuals did data analysis in a
spreadsheet, the DSUM, DMIN, DMAX, and DAVERAGE functions
received a major workout when used with a data table.



The pivot table was then introduced to the Data menu in Excel by Microsoft
in 1993. Pivot tables revolutionized business. Those strong database
capabilities seemed to be worn out and exhausted.

Customers complained sufficiently for Microsoft to add AVERAGEIF to
the armory of COUNTIF and SUMIF. Customers could have easily done
this by putting up a modest criterion range and utilizing DAVERAGE.

If the database functions did not need headers for the criterion range, they
would be significantly more popular.

The DSUM is quite strong in that it returns all records that have a given
criterion range (such as the region is East). In reality, though, your boss will
want to view the records where the area is Central and West rather than
East. When you start copying the DSUM function for other regions, you
notice you need two more cells to store each criterion range.

 

If you wanted to return the sales for 100 workers using 100 rows of DSUM,
you would require 200 cells of criterion range. Arranging those cells
vertically would make pointing to the relevant criterion range challenging.
(NB: Contemporary functions such as SUMIFS and FILTER give more
convenient methods to get results than DSUM).

Eleven of the twelve database functions are the same. DSUM,
DAVERAGE, DCOUNT, DCOUNTA, DMAX, DMIN, DPRODUCT,
DSTDEV, DSTDEVP, DVAR, and DVARP all execute the same function as
their non-D counterparts, but they enable for complicated criteria to include
records that fit certain criteria.

DCOUNT counts numeric cells and DCOUNTA counts nonblank cells to
spare you the trouble of digging up the perplexing few. DSTDEV and



DVAR compute the standard deviation and variance of a population sample,
respectively. DSTDEVP and DVARP compute the population’s standard
deviation and variance, respectively. DGET, the 12th database function,
takes the same inputs as DGET but behaves differently.

 

Using DSUM to conditionally sum records from a database
Every database function has three parameters. It is incredibly simple to set
up your first DSUM. The criterion argument provides the most freedom.
The syntax for the next 11 database functions is the same as this.

Syntax: DSUM(database,field,criteria)

The DSUM function adds records from a single field in a data collection if
the records fulfill certain conditions. The DSUM function accepts the
following parameters:

Database: The range of cells that comprise the list or database,
including the header row. A database is a collection of connected
data, where rows of data are records and columns of data are fields.

Column: This specifies which column is utilized in the function.
When defining a field, you have three options:

�       For Revenue, you may point to the cell with the fieldname,
such as H23.

�       The term Revenue may be used as a field argument.

�       The number 8 might be used to indicate that Revenue is the
database’s eighth field.

 



Criteria: This is the range of cells that contains the provided
conditions. For the criterion argument, you may use any range. The
criterion range usually comprises at least one column label and at
least one cell below the column label for setting a column condition.

 

Examples of logical function
The logical function group is one of Excel’s smallest, with just eight
functions. The IF function is simple to use and allows you to solve a wide
range of issues.

 

Making a choice using the IF function
Many computations in our life are not simple. Assume a manager provides
a bonus program if her team accomplishes its objectives. Perhaps a
commission plan includes a bonus if a specific profit target is attained. The
IF function may be used to solve these sorts of computations.

 

Syntax: IF(logical test,value if true,value if false)

The IF function takes three parameters. The first argument is any logical
test that yields a TRUE or FALSE answer.

 

Using the AND function to check for two or more conditions
The preceding instance had a single simple condition: the commission rate
changed if the value in column H was more than or equal to 50%.



In many circumstances, though, you may need to test for two or more
criteria. Assume a retail shop manager provides a $25 incentive for each
leather jacket sold on Fridays this month

Syntax: AND(logical1,logical2,...)

The parameters logical1,logical2,... are expressions ranging from one to 255
that evaluate to TRUE or FALSE. Only if all inputs are TRUE does the
method return TRUE.

 

Examples of text functions
The majority of people associate Excel with numbers. Excel excels at
working with numbers and allows you to create formulae to generate new
numbers. Excel has a plethora of formulae for working with text.

You may be annoyed at times when you get data from others and the
content is not in the format you need. Alternatively, the mainframe may
deliver client names in uppercase, or an employee in the next department
may enter a whole address into a single cell. Excel has text functions that
can handle all of these scenarios and more.

 

Text joining using TEXTJOIN
In past years, Microsoft released two new text-joining features. The
CONCAT function joins text in many cells. While CONCAT is superior to
the historical CONCATENATE function, it lacks the flexibility of the
fantastic TEXTJOIN function.



CONCAT has been added to a lengthy list of names. There is, however, no
space or comma between each item. You may define a delimiter using the
TEXTJOIN function. =TEXTJOIN(”, “,True,A2:A24) connects all of the
names in D6, and each name is separated by a comma and a space.

Furthermore, the third parameter to TEXTJOIN might be an array or a
three-dimensional reference. That is, you have the option of including or
excluding each name. =TEXTJOIN(”, “,True,IF(B2:B24=”Yes”,A2:A24,”)
might be used to connect just the names when column B indicates the
RSVP is Yes.

 

The TEXTJOIN function uses a delimiter to join a list or a span of text.

Prior to the introduction of TEXTJOIN in 2017, you would have had to use
=A2&” “&A3&” “&A4& Even the heritage CONCATENATE function was
unable to accept a diverse variety of cells. =CONCATENATE would have
been the formula (”A2”,” “,A3,” “,A4,” “,...).



 

To change text case, use LOWER, UPPER, or PROPER

Text is converted to or from capital letters using three functions: LOWER,
UPPER, and PROPER. The goods in column B were inserted haphazardly.
Some products used lowercase, while others used uppercase. Column C
employs =UPPER(B2) to make all the products uppercase.

 

 



CHAPTER EIGHT

How to create your first pivot table
Pivot tables work best with transactional data, which is raw data files
obtained straight from your company’s IT department.

To generate the greatest pivot tables, make sure your data adheres to the
following guidelines:

Make certain that each column has a one-cell header. Use different
headers for each column; don’t use the same heading for two
columns. If you want your headers to display in two rows, enter the
first word, press Alt+Enter, and then write the second.

If a column should include numeric data, no blank cells should be
allowed in the column. Instead of blanks, use zeros.

Avoid using blank rows or columns.

Remove any totals that are incorporated in your report.

Make sure the worksheet is not in Compatibility mode. When the
worksheet is in Compatibility mode, several pivot table capabilities
from Excel 2007–2019 are disabled.

If you add new data to the bottom of your data set every month, you
should seriously consider converting it to a table using Ctrl+T.
After a refresh, pivot tables generated from tables instantly take up
new rows copied to the bottom of the tables.

Whether your data contains months split over multiple columns,
return to the source software program to check if an alternative



representation of the data with months running down the rows is
available.

This data collection contains two years’ worth of transactional data.
Customer has a single text column. There is just one date column. Quantity,
Revenue, COGS, and Profit are all numerical columns.

 

Begin with a blank pivot table
The typical way to make a pivot table is to start with a blank one. Select one
cell from your data. From the Insert tab, choose PivotTable. The Create
PivotTable dialog box appears in Excel.



This dialog box validates the data range. Excel usually does this properly if
there are no blank rows or columns.

You can create the pivot table on a new blank worksheet or in an existing
place by using the Create PivotTable dialog box. If you want to create a
dashboard with many pivot tables, you may choose to place the pivot table
in J2 on this worksheet or adjacent to another existing pivot table or pivot
chart.

By clicking the Add This Data to The Data Model check box, you can
create a pivot table from a relational model.

 

 

 

 

Using the field list to add fields to your pivot table



If you began with a blank pivot table, you will see a PivotTable Fields. At
the top of the PivotTable Fields section is a list of fields from your original
data collection, and at the bottom are four drop zones. To create your report,
drag and drop fields into the drop zones at the bottom.

 

Using the field list to modify the pivot table report
Examine the Region, Product, and Revenue sections.

When you choose a text or date field, it goes to the Rows drop zone in the
PivotTable Fields list. When you check a numeric field, it goes to the
Values drop zone and the field type is changed to Sum of Field.



You can view the Sum of Revenue by Region and Product by selecting
Region, Product, and Revenue.

You may further personalize the pivot table by rearranging the fields in the
drop zones. Drag the Region field, for example, so that it is below the
Product field in the Rows drop zone.

 

How to rearrange a pivot table
The following are the drop zone parts of the PivotTable Fields list box:

Filter: This part is used to filter the report to just specified criteria.
The slicer function effectively replaces this part.

Rows: This part contains fields that display on the table’s left side.
When you pick the check boxes at the top of the field list, all text
fields are moved here by default.

Columns: This part contains fields that run along the top rows of
your table’s columns. (NB: This is referred to as a crosstab report
by old database experts).

Values: This section contains all the numeric fields summarized in
the table. Most values are automatically summed by default, but you
may modify the computation to an average, minimum, maximum,
or other calculation.

(NB: You can add fields to a drop zone by dragging them from the top of
the PivotTable Fields list or from one drop zone to another. Drag a field
from a drop zone to the outside of the PivotTable Fields list or uncheck it
from the field list to remove it from the drop zone).

 



Calculating and roll-ups with pivot tables
Pivot tables provide many more calculation choices. The ability to roll daily
dates up to months, quarters, and years is one of the most fantastic features.

 

Daily dates are organized into months, quarters, and years

Good pivot tables begin with high-quality transactional data. That
transactional data is almost always recorded with daily dates rather than
monthly summaries.

 

Follow these steps to create a summary by month, quarter, and year:

1. Begin with data including daily dates. Create a pivot table with
daily dates in the row field, regions in the columns, and sum of
revenue in the value area.

2. Choose a cell that has a date. Select Group Field from the
PivotTable Analyze tab.

3. Select Months, Quarters, and Years from the Grouping dialog box.
Click the OK button.

 

Follow these steps to create an intriguing alternative to the report:

1. To eliminate the Region and Quarter fields from the report,
uncheck the boxes next to them.

2. Move the Years field from the Rows to the Columns area by
dragging it from the Rows to the Columns area.



You now have a pivot table that displays totals by month and quarter as well
as compares years throughout the report. You’ll see that your pivot table
field list contains three date-related fields: The years and quarters fields are
both virtual. The months are included in the original Date field. Microsoft
made a good design move by allowing years and months to be pivoted to
various areas of the pivot table.

 

Adding calculations outside the pivot table
However, after you’ve grouped the dates in the pivot table, you won’t be
able to add a calculated field inside the pivot table, thus you’ll have to use
ordinary Excel to give the percent Growth column.

 

The most common stumbling block is step three. Take the following steps:

1. In D4, right-click the Grand Total and choose Remove Grand
Total.

2. In D4, create a heading called percent Growth.

3. Enter =C5/B5-1 in cell D5. If you utilize the mouse or arrow keys
while creating the formula, you will get stung by the GetPivotData
issue.

4. Cell D5 should be formatted as a percentage with one decimal
point.

5. In D5, double-click the fill handle to copy the formula to all rows.

 

Changing a field’s computation



By default, a numeric column with the default calculation of Sum will be
added to the pivot table. Excel has 10 more computations, including
Average, Count, Max, and Min.

The figures in this part begin with a fully new pivot table. You may follow
along by doing the following:

1. Remove the pivot table from the previous examples’ worksheets.
This memory-clears the pivot cache.

2. Choose one cell from the Data worksheet.

3. Select Insert > PivotTable.

4. Mark the Region, Product, and Revenue fields with a check.

5. Move Revenue to the Values section two more times. (NB: They
will display as Sum Of Revenue2 and Sum Of Revenue3 in the
pivot table).

6. Select Report Layout > Show In Tabular Form from the Design
tab.

7. Select Report Layout and Repeat All Item Labels from the
Design tab.

 

How to sort a pivot table
Customers are displayed alphabetically in all pivot tables in this chapter
thus far. In each of these cases, the report would be more interesting if it
were provided arranged by revenue rather than by client name.

When you click the AZ or ZA icons on the Data tab, Excel creates rules in
the Sort and More Sort Options dialog boxes.



Open a row field drop-down box and choose More Sort Options to
retrieve these choices later. More Sort Options may be accessed by
clicking the More button (Customer).

 

How to filter using slicers
Slicers are visual filters that make it simple to do a variety of ad-hoc
analysis. While slicers are simpler to use than the Report Filter, they have
the extra advantage of filtering numerous pivot tables and pivot charts built
from the same data source.

 

Adding slicers

Follow these procedures to add default slicers:

1. Choose one cell from your pivot table.



2. Click the Insert Slicer button on the PivotTable Analyze tab.

3. Select any fields that would make good filter fields. The region,
product, and years are chosen. Months, quarters, and dates would
also work.

4. Click the OK button.

 

Arranging the slicers

The slicers may be repositioned and resized. Choose a logical configuration
for the slicers. Here are a few instances.

Short entries can be found in the Region and Product slicers. Extend the
width of each slicer and then use the Columns option in the Slicer Tools
Options panel to increase each slicer to three columns.



The Year slicer is broader than necessary. There are also two more items in
the slicer (1/1/2024 and >12/31/2025) that are Auto Group leftovers. These
may be disabled in the Slicer Settings dialog box. Choose Slicer Settings
after selecting the slicer. Hide Items With No Data is also enabled.

 

Using Excel’s slicers
Choose that item to choose a single item from a slicer. To multiselect in
Excel, first select the symbol with three check marks at the top of the slicer.
Each item may now be selected by clicking on it.

You can also use the Ctrl key to pick several objects that are not adjacent,
or drag the mouse to select items that are nearby.

 

Items in other slicers may become inaccessible as a result of selections in
one slicer. In this situation, the items are pushed to the bottom of the list.
This indicates visually that the item is not accessible based on the current
criteria.

To remove a filter from a slicer, click the Funnel-X symbol in the slicer’s
upper right corner.

Slicers can be set up to filter many pivot tables and pivot charts at once. If
both pivot tables use the same data source, the slicers will have an effect on
both pivot tables.

 

If there are numerous pivot tables, proceed as follows:

1. Choose a slicer.



2. Select Report Connections from the ribbon’s Slicer Tools Options
menu.

3. Choose which pivot tables should be filtered by the slicer.

 

Using the row label filter to filter
To proceed, open the 16-Slicers.xlsx file and create a new pivot table.
Examine the fields Customer, Date, Quantity, Revenue, COGS, and Profit.
Open the Report Layout drop-down menu from the Design tab. Select
Tabular form, then Repeat All Item Labels. On the Design tab, tick the
Banded Rows box. You will get the pivot table as a result.

 

This drop-down menu has four distinct filter mechanisms:

For fields with text values, the Label Filters fly-out menu shows.
You may use this fly-out to find client names that include certain
words, begin, end, or fall between specific letters.

The Value Filters fly-out menu lets you filter consumers based on
values in the pivot table. Use the Value Filters fly-out if you only
want orders above $20,000 or if you only want to view the Top 10
clients.

Excel 2010 introduced the Search box, which is comparable to
using Label Filters but quicker.

Use the check boxes to exclude certain consumers, or use Select All
to clear or select all customers.

 



Clearing a filter
To clear all filters in the pivot table, click the Clear button in the Data tab’s
Sort & Filter group. To remove filters from a single field in the pivot table,
enter the filter drop-down menu and pick Clear Filter from “Field.”

 

 

Using check boxes to filter
The Customer drop-down menu lists all of the customers in the database.
Clear their check boxes in the filter list if you need to exclude a few
particular consumers.

The (Select All) option restores any previously cleared boxes. If all of the
boxes are already checked, selecting (Select All) clears them all.

Because it is simpler to choose three clients than it is to clear 27, if you
need to delete the majority of the items from the list of customers, you can
do it by following these steps:

1. If any customers have been cleared, choose Select All to reselect all
of them.

2. Tap Select All to delete all clients.

3. Choose which consumers you wish to see.



 



CHAPTER NINE

How to create a custom data type in Excel
What if you wish to design your own data types? You will need to define
them using Power Query.

The Name column will be shown in the cells, while the other columns will
be accessible through the Card or formulae. (NB: Ctrl+T will format the
data into a table).

To create a new data type, follow these steps:

1. Choose one cell from your data table.

2. Select From Sheet from the Data tab.

3. Select all the columns in the Power Query Editor. (NB: You may
achieve this by clicking on the first column’s heading and then
shifting-clicking on the final column’s heading).

4. On the Transform tab, on the far right, click the Create Data Type
button.

5. If you wish to delete any columns from the data type, click
Advanced on the Create Data Type dialog box.

6. Give the data type a name and choose which column will be shown
in Excel when the data type is presented as a single cell.

7. To exit the Create Data Type dialog box, click OK. Except for the
one column used as the Display Column, everything in the Power
Query editor is hidden.



8. Select Home > Close, and Load. A new worksheet with the data
type in column A is added to your workbook.

(NB: Now that the data type has been formed, you can now transfer the
query results to another worksheet and the data types will continue to
function).

 

How to use Power Query
The Power Query tools were designed to make it simpler to clean up sloppy
data. Assume that your IT department sends you a data set with certain
issues every day. Rather than waiting for IT to rebuild the query, you may
use Power Query to remember the steps required to clean the data. When
the IT department sends you a new file, just reload the query, and Excel will
go through all of the data purification stages again.

Column A has two distinct fields separated by a comma. The client column
is all capital letters. Columns D through O are a repeating set with varying
month values. To pivot this data, you must unpivot D:O, which results in an
additional date column and 12 times the number of rows.

 

Creating a Workflow
Assume that the IT department provides you this information once a month.
You may save the workbook in the same folder with the same name, and
then create your query in a new workbook. (NB: This workbook will be
programmed to constantly open the file C:FooUglyDataFromIT.xlsx).

Alternatively, the file they supply each month may need to be integrated
with all of the prior monthly files. In such situation, you should create a



new folder to house all of IT’s workbooks. This folder should not be used
for anything else. A new worksheet containing the query would be saved in
a separate folder. In this situation, you’d choose Get Data, From File, or
From Folder.

Either of the methods described above will make it simpler to update the
query in the future. The “wrong” technique is to open the file from IT and
then construct the query inside it.

 

Using Power Query to load data
Power Query can import data from the following sources:

Workbook, PDF, Text, CSV, XML, JSON, or files from a folder

SQL Server, Access, Analysis Services, Oracle, IBM DB2, MySQL,
PostgreSQL, Sybase, Teradata, and SAP HANA are examples of
databases.

SQL Database, Synapse Analytics, HDInsight (HDFS), Blob
Storage, Table Storage, Data Lake Storage, and Data Explorer are
all available in Azure.

Power BI: Make a pivot table that is linked to your company’s
Power BI data.

SharePoint, Exchange, Dynamics 365, Salesforce Objects, and
Salesforce Reports are all available online.

Other: Microsoft Query, SharePoint List, OData Feed, Hadoop File,
ActiveDirectory, Microsoft Exchange, ODBC, and OLEDB

 



The Get Data menu contains all of the previous items. The first icon on the
Data tab is this one. It may be found under the Get & Transform Data
section. Several of those options are repeated in the Get & Transform Data
section: From Text/CSV, From Web, and From Sheet.

Note: You might have utilized the legacy connections in the past.
Previously, the Data tab in Excel included seven icons: From Access,
From Web, From Text, From SQL Server, From OData Data Feed, From
XML Data Import, and From Data Connection Wizard.

While these seven instructions still exist, they are no longer visible on the
ribbon. Go to File, Options, Data if you need to access the old commands.
You may restore the icons by using the different checkboxes in the Show
Legacy Data Import Wizards section. Any icons you choose here will
display in the Data, Get Data, and Legacy Wizards sections.

 



Loading data from a single Excel workbook
Make a new workbook using a blank template. Make a name for the
worksheet, such as PowerQueryToLoadUglyData.xlsx.

Select Data > Obtain Information > From Workbook > From
File.



Depending on the source, you will need to navigate to the file, supply a
database connect string, or offer a URL.

The Navigator dialog box will be shown. Nothing is shown in the Data
Preview on the right at first. Click on the Data worksheet on the left side
of the dialog box. The Preview will be shown on the right.

You have the option to Load, Transform Data, or Cancel below the Preview.
You should choose Transform Data so that you may define the data cleanup
processes.

 

Unpivoting data in Power Query
It is fairly typical to encounter data that spans months or years across
columns. This structure’s pivot tables are quite difficult to use. Previously,
repairing the data structure required repetitive copying and pasting or using
an esoteric method called Multiple Consolidation Ranges. This technique
is made quite easy with Power Query.

 

The first four columns have been chosen. Transform, Unpivot Columns,
and Unpivot Other Columns are the options.

Choose the Date column. On the Transform tab, look at the Data Type
value. These dates are being treated as text by Power Query. Select Date
from the Data Type drop-down option when the Date column is chosen.

If there are customers who had no revenue in a certain month, you may
eliminate such records by using the Filter drop-down option on the Value
column and unchecking 0 values.



 

Adding columns in Power Query
The new Column from Examples tool in Power Query is similar to Excel’s
Flash Fill. Column From Examples generates a formula that may be reused
in the future. To add a column in Excel 2016, you had to construct a new
formula.

The formula language is not the same as Excel. Date is the method for
obtaining a month name from a date. MonthName([Date]). Power Query
refused to accept a date. Date or monthname Monthname. Date has to be
typed. MonthName in all capital letters.

Today, the new Column from Examples tool makes the procedure easier.
Take the following steps:

1. Click on the Date column.

2. Select Add Column, Column From Examples in Power Query.
On the far right side of the window, a new Column1 emerges.

3. In Column 1, click the first cell and write January.

4. Power Query will provide a Month Name From Date option. Click
the OK button.

Month Name will be added as a new column in Power Query. Choose View,
Formula Bar if you don’t see the formula bar above your data. The formula
bar demonstrates that Month Name From Date employs the Date.
MonthName([Month]) is a function. This is helpful if you want to learn
Power Query formulae.

 



How to append one worksheet from every workbook in a folder
The greatest Power Query method is to consolidate all single-sheet
workbooks from a single folder.

Select Get Data, From File, From Folder from Excel, and then specify
the folder. Power Query will provide a list of the files in the folder. Select
Combine & Edit. Select the appropriate worksheet from the Navigator
screen.

Also, Power Query is intelligent enough to highlight the first row of the
first file as headers. It will then remove all other headers from the
remaining workbooks.

If you have additional columns in certain files, those columns will display
in the final query, along with the phrase “null” for entries that do not
contain the extra column.

Additionally, if new workbooks are added to the folder over time, you can
simply click Refresh to have Excel refresh everything from the folder.

 



How to add worksheets from one workbook to another
What if you have a workbook with many worksheets that you need to
combine? You must ensure that all spreadsheets have the same columns in
the same order.

 

Take the following steps:

1. Assume you have a workbook with a number of worksheets.
Because it merely includes boilerplate instructions, one worksheet
does not need to be merged. Close the workbook and begin over
with a fresh blank workbook.

2. Select Data, Get Data, and From Workbook.

3. Locate and select the worksheet.

4. At the top left of the Navigator, there is a folder with the name of
the workbook and a list of worksheets. Select Transform Data
from the context menu when you right-click on the folder name.
This step is not evident, yet it is critical for combining worksheets.

5. The Power Query Editor is launched. There will be one row for
each worksheet and a second set of rows containing the worksheet’s
secret names. To delete the DefinedName entries, use the Filter
drop-down option in the Kind column. Remove any sheets that
should not be joined by using the Filter drop-down option in the
Name column.

6. Select Remove Other Columns from the menu that appears when
you right-click the Data heading.



7. To the right of the Data heading, click the Expand symbol.
Uncheck the Use Original Column Name As Prefix box. Click the
OK button. All records from all worksheets are combined by the
Power Query Editor. It should be noted that the headers in row 1
should be promoted. The remaining headers at the top of each
spreadsheet must be removed.

8. Select Use First Row As Headers from the Power Query Editor
Home menu.

9. The first column in this data collection has the header “Region.”
Deselect Region from the filter drop-down option for this column.
(NB: This will delete all of the heads from the data).

10.                    Select Close & Load from the Home tab. (NB: All records
from all worksheets in the other workbook will be included in the
resultant data collection).

 

How to add automatic subtotals
If you have a complex data database, you may wish to add subtotals to each
set of entries. If your data just has one field that identifies the groups, you
may rapidly add the subtotals using the Subtotals command.

 

To add subtotals to a data collection, follow these steps:

1. Sort the data set according to your group field. Column D,
Customer, is the case in this scenario. Select one of the cells in that
column, then Data, Sort & Filter, AZ.

2. Choose one cell from your data collection.



3. Choose Data, Outline, and Subtotal.

4. Change the At Each Change In drop-down choice in the Subtotal
dialog box to suit your group field.

5. Check that the Use Function is set to Sum.

6. In the Add Subtotal To list, choose the field for each field you wish
to total.

 

How to subtotal multiple fields
Assume you wish to add subtotals based on location and product. The
subtotals will be added twice. Make sure the Replace Current Subtotals
check box is unchecked in the second Subtotal command.

Check that your data is appropriately organized. You may sort by area and
then by product using the Sort dialog box, or you can follow these
procedures, which take just four clicks:

 

1. Choose one of the cells in the Product column.

2. On the Data tab, click the AZ button.

3. Choose one of the cells in the Region column.

4. On the Data tab, click the AZ button.

This combination of steps successfully sorts by product inside the area since
the sort in step 4 maintains the ties from the prior sequence.

(NB: It is critical to add subtotals to the outer group first.  Rerun the
Subtotals command. This time, indicate Each Product Change. Uncheck
the Replace Current Subtotals box).



There are now four Group and Outline buttons. When you hit the #3 button,
you’ll see product and region totals. It’s worth noting that Excel allows for
a maximum of eight Group and Outline buttons, allowing you to create up
to six layers of subtotals.

 

Using subtotals as a tool
To the left of column A, you’ll see three new buttons labeled 1, 2, and 3.
Those buttons are known as the Group and Outline buttons, and they were
automatically added by the Subtotals command. They are essential for
further subtotal analysis.

 

 

Displaying a one-page summary that simply includes the subtotals

To the left of and immediately above cell A1, click the #2 button. Excel
conceals all detail rows except the customer subtotals and the Grand Total
row.

You would have a one-page summary of the 500+ rows of data after
adjusting the print area.

Excel conceals everything but the Grand Total when you select the #1
Group and Outline button. When you click the #3 button, Excel returns to
the detail rows.

 

Sorting the collapsed subtotal view such that the biggest customers
appear first



You have the customers listed alphabetically. Your management, on the
other hand, would most likely prefer to see the biggest clients at the top of
the report.

Consider this suggestion, though. The subtotal for Excel4Apps in row 211
is one of the major consumers in the group, summing together data from
rows 151 through 210. If you attempt to sort in descending order and the
data in row 211 gets to row 3, the algorithm that looks at 60 rows of data
will almost likely return a #REF! error.

 

However, you can quickly sort data while it is in the compressed #2 view.
Take the following steps:

1. Perform the subtotals stated previously.

2. Click the #2 Group and Outline button to collapse the subtotals.

3. Choose a single cell in your revenue column.

4. On the Data tab, click the ZA button to sort in descending order.

 

How to filter records
The function that was formerly known as AutoFilter is now renamed as
Filter. The command includes additional functions in addition to its new
name. Filtering works on any range of data that has headers in the first row.
It supports both table-defined ranges and conventional ranges.

 

Microsoft introduced the following functionality when they renamed
AutoFilter to Filter:



The Search field allows you to look for values that include a
wildcard. You can add the results of the search to a previous filter.
As a result, you could instantly discover all entries containing the
words “bank” or “credit union.”

The Filter drop-down menu has a multiselection option. It is now
simple to choose two, three, or 10 values from the filter. On the
other hand, filtering to a single value is little more difficult since
you must first uncheck the (Select All) option.

You can narrow down your search by color or icon set.

You can also filter text columns based on cells that start with, finish
with, or include a value.

Number columns may be filtered based on cells that are greater
than, less than, or between values. You have the option of selecting
Top 10, Above Average, or Below Average.

Date data can be filtered by year or month. You may narrow your
search by conceptual values like This Month, Last Quarter, or Year
To Date.

You have the option of filtering by selection. Rather of selecting a
value from the Filter drop-down box, you may use Filter By
Selection to limit the data to that value.

When one column has values of the same kind, the different functionalities
operate well. For example, if you have dates in a column, Excel wants all
columns except the header to be dates. Based on what it sees in the column,
Excel provides specific text, numeric, or date forms.

 

Using a filter



The toggle icon for the filter drop-down menus turns the functionality on
and off. To enable the functionality, just click the symbol once. To disable
the function, click the symbol once again. Before you can use the filter, you
must first choose one cell from your data range. There should be no blank
rows or columns in the filtered range.

 

You can enable the filter drop-down menus using any of the following
methods:

Select Sort & Filter, then Filter, from the Data tab.

Select Filter from the Sort & Filter drop-down option on the Home
tab.

Use a table format to format a range.

Right-click any cell, choose Filter, and then choose one of the Filter
choices. In addition to running the filter, this will enable the Filter
function if it was not already enabled.

Select any value and then the AutoFilter icon from the QAT. Excel
has had the Filter By Selection capability since 2003, but the
symbol has never been featured in the normal user interface. In
addition, this icon has always been labeled incorrectly in the
Customize dialog box.

When you enable the filter, a drop-down menu arrow appears next to each
heading in the range.

 

Using the Advanced Filter command



Excel still has the Advanced Filter command. Microsoft should rename this
function since it is quite strong and performs much more than filtering. The
Advanced Filter command, on the other hand, is one of the most perplexing
operations in Excel. This is especially true since the Advanced Filter may
be used in eight distinct ways, each with somewhat different processes.

 

Note: Filtered results may only be copied to the current sheet, not to a
new sheet. If you start on a blank sheet, you may indicate that you wish to
filter data from another sheet and bring it into the current sheet.

The Advanced Filter dialog box has three options, and based on your
selections for those three options, you may have the following potential
combinations:

You have the option of Filtering In Place or Copying To A New
Location.

You may filter using a criterion range or without any criteria.

You have the option of returning all matched values or simply the
unique ones.

In actuality, Advanced Filter may be used in more than eight ways. If you
opt to transfer records to a new location, you may either replicate all the
input columns in their original order or select a subset of columns and/or a
new column sequence.

You can create a basic filter for a single column. For numerous columns,
you may combine any number of filters. You can create very complicated
filters using any formula you can think of. You might also use no criterion
at all. When you wish to use Advanced Filter to extract unique values or to
reorganize the sequence of columns, it is normal to utilize no criteria.



 

Follow these procedures to apply Advanced Filter to a data set:

1. Copy one or more headers from your data collection to a blank area
of the worksheet if you are using criteria. List the value(s) you wish
to include under each header.

2. If you’re using an output range and wish to reorganize the columns
or include a subset of them, copy the headers into the correct order
in a blank part of the worksheet. The output range may be any blank
cell if you want all of the original columns in their original order.

3. Choose a cell from your data range.

4. Choose Data, Sort & Filter, and Advanced.

5. Confirm that the list range includes your original data collection.

6. Enter the criterion range if you are using criteria.

7. Select Copy to Another Place if you wish to move the matched
records to an other location. (NB: This allows the Copy To
reference box. Fill in the blanks with the output range).

8. Select Unique Records Only if you want the output range to
include only unique values. If your output range has a single field, a
list of the values in that field that meet the requirements is
presented. If your output range includes two or more fields, each
distinct combination of those two or more fields is presented.

9. Click OK to run the filter.

Combining duplicates and adding values
Each client appears on the list one or more times, with sales, cost, and profit
figures. You want to know the entire sales and profit for each client, in



addition to obtaining a unique list of customers. A pivot table may be used
to calculate the total sales for each client. Alternatively, you may utilize the
data tools to reduce the table to one entry for each client.

Follow these procedures to utilize the Consolidate function to total sales
from all records for that customer:

1. Rather of pre-selecting the data, move the cell pointer to a blank
portion of the worksheet.

2. Choose Data, Data Tools, and Consolidate.

3. In the Consolidate dialog box, in the Reference box, enter the
reference to your data. The data will be merged depending on the
field in the range’s left column. If you have numerous customer
lists, you may add more ranges by clicking the Add button.

4. In the Use Labels In section, make sure the Top Row and Left
Column check boxes are checked.

5. Select OK.

 



CHAPTER TEN

Excel tips and tricks

Inserting a symbol in a cell
Many symbols are usually inserted using obscure key combinations. You do
not, however, have to learn any of them. Instead, you may open the Symbol
dialog box by clicking the Symbol icon on the Insert tab.

You can navigate through various subsets of the current typeface in the
Symbol dialog box. When you’ve found the right symbol, select it and press
the Insert button.

 

Watching the results of a distant cell

You may need to keep an eye on a single result on a worksheet different
than the one you’re now in at times. For instance, you can have a workbook
in which assumptions on numerous pages result in a final ROI. It would be
useful to know the impact on ROI when you adjust the assumptions.

It might be time consuming to repeatedly go back and forth between the
results worksheet and the changes worksheet after each modification.
Instead, you may configure a watch to display the current value of the
distant cell (s).

 

Follow these steps to set up a watch:



1. Choose Formulas, Watch Window to bring up the floating Watch
Window dialog box on top of the worksheet.

2. In the Watch Window dialog box, click Add Watch.

3. In the Add Watch dialog box, click the RefEdit button, then
choose the cells to monitor.

4. To add the cell(s) to the Watch Window dialog box, click Add.
Steps 2–4 should be repeated as needed.

5. Move the Watch Window dialog box above your worksheet to an
out-of-the-way area so you may continue working. It is important to
note that the Watch Window may be docked above the formula bar.

 

(NB: The Watch Window dialog box displays the current value of the
monitored cells whenever you make a modification to the worksheet).

 

Protecting a worksheet
If you have a lot of formulae in a worksheet, you may wish to keep them
from being changed by others. In most cases, your worksheet will include
some input variables at the top. You may want to allow those elements to be
modified, but you may not want to allow changes to your formulae.

 

To secure a worksheet, do the following steps:

1. In your worksheet, select the input cells. These are the cells you
want someone to be able to modify.



2. Hit Ctrl+1 or go to the Home tab’s Cells group and pick Format,
Format Cells.

3. Clear the Locked check box on the Format Cells dialog box’s
Protection tab. Click the OK button.

4. Choose Review > Protect Sheet.

5. Change what can happen in the protected worksheet, if desired.

6. Click OK to activate the protection.

 

Editing an equation
The Insert tab’s Equation drop-down menu has eight prebuilt equations. If
you need one of these equations, you may have to choose it from the drop-
down option.

Insert a shape in the worksheet first if you need to create another equation.
Insert, Equation, Insert New Equation when the shape is chosen. The form
now has a blank equation.

It may seem to be a minor detail, but you must be within the equation to
access the Equation Tools Design tab. To input a mathematical symbol, use
the ribbon to access the different drop-down choices. Three placeholders
are used for certain symbols. These are little text boxes into which you may
enter different values.

 

Calculating a formula in slow motion
If you have a particularly complex formula, you can watch Excel compute it
in slow motion. This might assist you in identifying any logical problems in



the spreadsheet.

Follow these steps to assess a formula in slow motion:

1. Locate the cell containing the formula.

2. Formulas are chosen and evaluated. The formula is shown in the
Evaluate Formula dialog box. One of the formula’s elements is
highlighted, indicating that it will be computed next.

3. Click Evaluate to view the value of the highlighted element right
away.

4. Instead of clicking Evaluate, click Step In to see how that element
is computed. Excel displays the element’s formula.

5. Finally, the final level is assigned a number. Step Out to return to
the previous level of the dialog box.

6. Continue to click Evaluate until you reach the result indicated in the
cell.

 

Inserting and exploring 3D models
Almost 50% of all manufacturing organizations use 3D printing as a quick
prototyping tool.

Excel supports the following file formats: Filmbox (*.fbx), Object (*.obj),
3D Manufacturing Format (*.3mf), Polygon (*.ply), StereoLithography
(*.stl), and Binary GL Transmission (*.glb).

Select 3D Models from the Insert tab. Microsoft provides a few
example files, but you may import any file you have.

 



Using the inking tools and the Action Pen
The Draw tab on the ribbon is most likely a well-used tool in PowerPoint.
Because the functionality had previously been built for PowerPoint, it was
made available to Word and Excel.

 

If you don’t see the Draw tab in Excel, do the following:

1. Select Customize the Ribbon from the menu that appears when
you right-click the ribbon.

2. On the right side of the Excel Options window, there is a list of all
of Excel’s built-in tabs. Locate and choose the Draw tab.

3. To dismiss Excel Options, click OK.

(NB: Microsoft introduced the Action Pen to the Drawing Tools collection
on the right side. You may draw numbers or letters with the Action Pen,
and Excel will transform them to text or numbers).

 

 

 

 



CHAPTER ELEVEN

Auditing worksheets using Inquire
You can activate the Inquire add-in if you have Office Pro Plus or a
Microsoft 356 E3 subscription or above. The add-in provides tools for
detecting possible issues in workbooks. You may see a visual map of
connections, flag cells that indicate possible issues, and compare two
versions of the same worksheet.

Select File > Options > Add-Ins to enable Inquire.

Choose Manage Com Add-Ins at the bottom of the screen and
press Go.

Select Inquire and press OK.

 

Assume you have a workbook that you want to email to a coworker for
evaluation. When you get the modified version of the workbook from your
coworker, you want to examine whether any modifications have been made
to the workbook.

Rename one or both workbooks so that you know which the original is and
which the modified version is. Launch both workbooks. Select Compare
Files from the Inquire tab. In the Compare drop-down option, choose the
newer, modified version of the worksheet. In the To drop-down option,
choose the original worksheet. This may seem to be a step back from how
you would expect the files to be supplied.

(NB: The findings are shown in the Spreadsheet Compare tool once you
click Compare. If you don’t want to modify the cell formatting, uncheck



the box in the bottom left corner of the window).

The two workbooks are shown at the top of the window. Any modifications
are color coded to match the color legend in the bottom left.

 

Formatting with styles
Instead of using the Font group of the Home tab’s options, you may prepare
a report using the built-in cell styles. For more than a decade, cell styles
have been popular in Microsoft Word. They were accessible in previous
versions of Excel, but since they were not included to the Formatting
toolbar, few users used them.

Cell styles have the benefit of allowing you to change the appearance and
feel of a report by selecting a theme from the Page Layout tab.

A menu option in the Cell Styles gallery allows you to add extra styles to a
workbook. Using cell styles as an alternative to the usual manner of
formatting is an intriguing option.

 

Using traditional formatting
Formatting is usually done via the Format Cells dialog box or with the
formatting icons on the Home tab.

The classic formatting icons in Excel are found on the Home tab in the
Font, Alignment, and Number groups. Additional column and row
formatting instructions may be found in the Cells group on the Home tab’s
Format drop-down menu.

 



If your preferred setting is not on the Home tab, you may reach it through
one of the four entry pathways to the Format Cells dialog box, which
includes extra options such as Shrink To Fit, StrikeThrough, and other
border settings:

Press Ctrl+1, which is Ctrl plus one. Ctrl+Shift+F will bring up the
Font tab in the same dialog box.

In the Font, Alignment, or Number groups, click the dialog box
launcher icons in the lower-right corner. Each icon opens the dialog
box, focusing on a particular tab.

Select Format Cells from the context menu when you right-click
any cell.

On the Home tab, under the cells group, choose Format Cells from
the Format drop-down menu.

 

The Format Cells dialog box has the six tabs shown below:

Number: Provides complete control over numeric formatting. You
may choose among 96,885 built-in formats or build your own using
the Custom category.

Alignment: Provides options for horizontal and vertical alignment,
rotation, wrapping, merging, and shrinking to fit.

Font: This option controls the font, size, style, underlining, color,
strikethrough, superscript, and subscript.

Border: Sets the line style and color for each cell’s four borders and
diagonals.

Fill: Over 16 million fill colors and patterns are available.



Protection: When the sheet is protected, it may be used to lock or
unlock cells or conceal their contents from view.

Using the Home tab to switch between numeric formats
If you’ve ever gone hardware shopping, you’ve undoubtedly seen how a
general-purpose store may have nearly everything you need but seldom
precisely what you need. At this point, you probably regret stopping at the
general-purpose store instead of driving another mile down the road to
Home Depot or Lowe’s, where you can always locate precisely what you
need.

 

Using the Number group on the Home page is similar to buying at a general
store. It includes a lot of number formatting options, but they aren’t always
what you need. When this occurs, you are sent to the Number tab of the
Format Cells dialog box.

To begin, there are three icons: one for currency, one for percentage, and
one for comma style. The Percentage icon is beneficial. Unfortunately, the
Currency and Comma symbols apply an Accounting style to a cell, which is
unsuitable for anybody other than accountants. Furthermore, these three
icons are not toggle buttons, which means that when you use one of them,
the only option for rapidly returning to a generic style is Undo.

The Decimal Increase and Decrease icons are helpful. Each of these buttons
causes Excel to display one more or one fewer decimal place. If all of your
numbers have two decimal places, two clicks on the Decrease Decimal
button will remedy the issue.

 



The following list contains several comments and warnings regarding using
the number styles from the Home tab’s drop-down menu:

A number format is used in general format. If necessary, decimal
places are shown. There is no usage of a thousands separator. A
negative number is denoted by a minus sign before the number.

There is no thousands separator in the number. Even with numbers
that do not need decimal places, it imposes two decimal places.

Currency is a format that everyone may use. The currency sign
appears just before the number. Every number is stated to two
decimal places. Negative numbers are denoted by a hyphen before
the number.

Currency symbols are placed to the left border of the cell. Positive
numbers appear one character from the cell’s right edge, allowing
them to match up with negative numbers.

When percentage is chosen from the drop-down menu, it utilizes
two decimal places. This is one format where the ribbon icon rather
than the Format Cells dialog box is preferable.

Fraction displays a fraction with a one-digit divisor by default. If
you have a number like 0.925, various Excel number formats will
accurately display it as 15/16. Regrettably, the Fraction option in
this drop-down menu only allows only one-digit divisors.

 

 

Changing numeric formats in the Format Cells dialog box by using
built-in formats



The number formats available in the Format Cells dialog box are more
extensive than those available on the Home tab. Only the Format Cells
dialog box provides access to my preferred number format.

The Format Cells dialog box may be accessed by selecting the dialog box
launcher icon in the lower-right corner of the Number group on the Home
tab. The Number tab is the active tab when you access the Format Cells
dialog box in this manner.

On the left side of the Number tab, there are twelve categories. Each of the
General and Text categories has a single setting. The Custom category
allows you to create any number format by using formatting codes. The
next nine categories each provide a set of controls for modifying the
numeric format.

 

Using thousands separators with numeric formatting
The thousands separators make it easier to read the number. The decimal
places may be removed from the numbers. Microsoft does not provide
buttons to pick this format on the Home page. The comma button is an ideal
location for it, however Microsoft allocates it to the accounting format.

 

Follow these procedures to format cells in numeric format:

1. To open the Format Cells dialog box, use Ctrl+1.

2. From the Number tab, choose the Number category.

3. Check the Use 1000 Separator box.

4. Set the Decimal Places spin button to 0 if desired.



5. Choose a technique for showing negative integers if desired.

 

Understanding Themes
A theme is a set of color schemes, typefaces, and effects. Office comes with
20 pre-installed themes. If you’ve updated from a prior version of
Windows, you may also download new themes from Office Online or create
your own.

 

Themes are shared in simple XML files, allowing them to be distributed
across an organization. A theme is made up of the following elements:

Fonts: A theme includes two fonts: one for body text and another
for titles. Fonts are used more often in PowerPoint and Word than in
Excel. Styles in Excel, on the other hand, make use of typefaces as
well.

 

Colors: There are 12 colors in total: four for text and backgrounds,
six for accent colors used in charts and table accents, and two for
hyperlinks. One of the two colors for hyperlinks denotes followed
hyperlinks, while the other color shows unfollowed URLs. The
colors given here are shown at the top of the Color Chooser.

 

Object effects, such as bevel and line style, are included in each
theme.

 



Selecting a New Theme
The Page Layout tab is where you manage your themes. The four drop-
down menus accessible in the Themes group are listed below:

Themes: Allows you to choose between the pre-installed themes.

Colors: Changes the color scheme to allow you to utilize colors
from another theme.

Fonts: Allows you to use fonts from a different theme.

Effects: Allows you to utilize effects from a different theme.

(NB: Theme changes have an impact on charts, tables, SmartArt
diagrams, and added objects).

To switch to a different theme, do the following:

1. Position your worksheet such that any themed components, such as
tables or charts, are visible on the right side of the screen.

2. Select the Themes drop-down menu from the Themes group from
the Page Layout tab.

3. Hover your mouse over the different themes. The worksheet is
refreshed to reflect the updated colors, fonts, and effects.

4. When you’ve found a theme you like, click it to apply it to the
workbook.

If you are just interested in the accent colors, go to the Themes group and
pick the Colors drop-down option to view the accent colors used in each
theme. It’s worth noting that this drop-down menu has a grayscale option
that the Themes drop-down menu does not.

 



 



 



CHAPTER TWELVE

How to share documents with others
There are at least three methods for sharing a cloud-stored document. The
Excel team introduced the possibility to share the workbook in the Save
This File dialog to make sharing more visible.

 

Sharing documents with others
From a new document, use Ctrl+S to bring up the contemporary Save This
File window. Once you’ve selected an online location, the same dialog
allows you to optionally collaborate with others.

 

Using the Share button to share
If you wish to share the workbook later, click the Share button in the upper
right corner of the Excel screen. In this dialog, you have additional options.
You have the option of creating a connection. Use the Pencil symbol to
choose whether you want the user to be able to modify or merely read.

In the Link Settings window, you can specify an expiry date, block the
document from being downloaded, and perform other things by clicking the
Link Settings button. It is important to note that Block Download is only
possible if you deselect Allow Editing.

 

Sharing by mentioning in a modern comment



The third method of distributing the file is to @Mention someone in a
remark or to give a task to them through a comment. More about mentions
and tasks may be found later in this chapter.

You might readily envisage sharing a workbook with three people of your
department. In a remark, someone poses a query concerning a cell. “This
isn’t my region,” the respondent responds. Let us consult with @Joe in
Finance.” Despite the fact that Joe from Finance was not one of the
contributors, the workbook has now been shared with him so that he may
respond to the criticism.

After a few weeks of working on the paper, you may have a large number
of persons who were named and now have access to it. You’ll need a
mechanism to keep track of who has access.

 

Sorting and filtering using Sheet Views
How would Excel know how to compute these formulae if each user could
filter independently?

The issue was resolved in 2019. To set up and handle numerous data views,
use the new Sheet View group on the left side of the View tab.

The “actual” version of the worksheet is called Default. When a user
attempts to Sort or Filter, they are urged to have the action display
exclusively for them. If they choose this option, a new view named
Temporary View is produced. If you like the temporary view and wish to
use it again, click Keep and give it a name like BillView.

Once you’ve made a view permanent, everyone working on it will be able
to choose it. When you restrict the data set to just Bill records, the Others



Are Making Changes dialog box displays. It asks whether you want to view
other people’s sorting and filtering. You have the option of seeing just mine
or seeing everyone’s. The obvious alternative is to just view your filters.

If you dismiss the notice, you may use the New icon to create a new Sheet
View.

 

Excel provides a new Sheet View called Temporary View if you choose See
Just Mine. This indicates that you are the only one who can see this version
of the data.

External workbooks that connect to this worksheet, on the other hand, will
acquire the Total Visible from the Default View. Also, the column letters
and row numbers now have a black backdrop. This serves as a reminder
that you are in Sheet View.

When you have a Temporary View, you can return to the Default View by
clicking the Exit symbol on the View tab. If you wish to return to this Sheet
View regularly, utilize the Keep icon and give the view a name.

It’s worth noting that if you build a view named BillView, everyone
participating will have the opportunity to switch to that view.

 



Editing the same workbook at the same time
When you ask someone to collaborate on a workbook, they will get an
email with a link to the workbook. The worksheet will also appear in the
Shared with Me and Recommended for Me sections of the Excel Home
screen for the other individual.

Previously, if many users had access to the same worksheet, it was a “one-
at-a-time” scenario. You may now all edit at the same time. (NB: The only
restriction is that you should not alter the same cell at the same time).

 

Using presence to see who else is editing
Numerous cell pointers appear when multiple users are editing the same
worksheet at the same time. In your session, the active cell will be green.
Each individual editing will be given a separate color cell pointer.

The presence of little circles in the upper right corner of the Excel window
shows who is present and editing the file. Hover your mouse over any circle
to see their complete name and the cell they are presently working on.

It takes some practice to figure out which cell pointer belongs to you. Some
users on UserVoice have requested the option to conceal all presence
features since it might be irritating to watch the cell pointers for many peers
moving across the screen.

 

Etiquette for editing at the same time
You’ll be OK if you don’t choose any cells that other people are modifying.
When someone begins altering a cell on another computer, an animated



three dots will show next to that cell. This signifies that the cell is being
edited by someone else.

Wait until they have finished modifying the cell and the cell has updated.
After then, you may modify the cell.

If two persons make changes to the same cell at the same time, Excel will
pick a winner. In most circumstances, the last individual to update the cell
“wins,” but not always. Coauthoring is supported in various ways by
different endpoints. Sometimes, a person using an earlier version of Excel
will not have complete coauthoring functionality, and that person will
always win. You may prevent the issue by avoiding picking a cell that is
being edited by someone else.

 

How to store documents in the cloud
To collaborate successfully, the document must be saved on the cloud.
Today, this translates to OneDrive.

Additionally, your workbooks will always be accessible if you save them to
OneDrive. You are not required to copy them on a flash drive. You don’t
have to keep the flash drive in your pocket. If you work three days from
home and two days in the office each week, the files will always be
accessible in any location.

They will be provided with one caveat: they will be available until the
Internet fails. Even in these instances, the Windows and Mac versions of
Excel will allow you to continue working on a document. When the Internet
is restored, the changes you make will be aggregated and applied to the
online version of the workbook.



Here’s a crucial distinction: Store your worksheets on the cloud while
continuing to work in the desktop version of Excel.

People seem to believe that since a document is saved on the cloud, you
must work in Excel Online. Perhaps your boss requires immediate action,
and you are visiting your grandma, who does not have Excel. In such
scenario, you might use Excel Online to make the necessary changes.

 

There is one instance where you may wish to experiment with Excel
Online. New features have been introduced first in Excel Online, then in
Windows and Mac, and ultimately in Excel for mobile devices.

 

Tracking who did what in the workbook

Most people’s concern when requesting colleagues to collaborate on a
worksheet is that someone would mistakenly change a formula, sort a
portion of the data, and so on. You could secure sheets and workbooks on
desktop Excel, but as of June 2021, such proactive techniques of securing a
workbook are no longer available in Excel Online.

Microsoft has given tools to enable you reactively erase unwanted
modifications made by others until sheet protection is added to Excel
Online:

The Show Updates tool displays all workbook changes made in the
previous 60 days. You can see everything written into the cell, as
well as who did it and when. If a cell has been updated many times,
Show Changes will display the whole history. You have the option
of reverting to any prior setting.



Version History displays the workbook’s latest 25 revisions. The
modifications made in each version are visible in Excel Online. You
can restore to a previous version or save a copy of a previous
version.

 

Using threaded comments, mentions, and assigning tasks
Previously, a single cell could only contain one note. The new threaded
comments feature is one of the enhancements to the collaborative
environment. Select a cell and then Review, New Comment to begin a
comment thread.

While composing your remark, you may address it to a specific individual
by inserting a @ symbol followed by the person’s name. This is referred to
as a @Mention (pronounced “at mention”).

As of 2021, the @Mention system will need Microsoft Exchange’s Active
Directory functionality. This implies that @Mentions will not operate in
Excel’s home or consumer versions. Microsoft would love to find out how
to make @Mentions work for home users, so it may be operational by the
time you read this.

 

More so, you can create a task for someone if you @Mention them in a
remark. A popup opens after you type the @Mention, asking whether you
wish to create a task. Task creation is currently being rolled out as a new
feature. It’s functioning in Excel Online, but it has to be available on
desktop and mobile devices as well. (NB: However, you may expect them
to integrate tasks with either Outlook Tasks or Microsoft To Do).



Each new comment has a green paper aircraft symbol in the bottom left
corner. To add a remark to a cell, click this symbol.

 



CHAPTER THIRTEEN

Printing

How to work with page breaks
There are two types of page breaks: automatic and manual. When Excel hits
the bottom or right margin of a physical page, an automatic page break
happens. These page breaks vary automatically when you modify the
margins, add or remove rows, or change the height of certain rows on the
page.

Initially, the spreadsheet does not display automatic page breaks. However,
if you exit Print Preview and return to Normal view, automatic page breaks
are shown in the document as a thin dashed line. Page Layout view and
Page Break Preview mode both show automatic page breaks.

To disable the page breaks, go to File, Options, Advanced, Display Options
for This Worksheet and uncheck the Show Page Breaks option. If this is
something you do regularly, the shortcut keys /fta followed by Alt+k will
bring you there.

You can manually insert page breaks where you wish to start a new page in
rows or columns. For example, at the beginning of a new part of a report,
you may wish to place a manual page break. A manual page break does not
alter in response to changes in the rows of the worksheet.

 

Adding page breaks manually
Follow these procedures to manually insert a page break at a certain row:



1. Click the row number that should be the first row on the new page
to choose a full row. Alternatively, choose the cell in that row’s
column A.

2. Select Page Setup, Breaks, and Insert Page Break from the Page
Layout tab.

Follow these procedures to manually insert a page break at a certain
column:

1. Click the letter above the column that should be the first column on
the new page to choose a whole column. Alternatively, choose row
1 from that column.

2. Select Page Setup, Breaks, and Insert Page Break from the Page
Layout tab.

 

Note: When you insert a page break when the cell pointer is outside row 1
or column A, Excel inserts a row page break and a column page break at
the same time. This is almost never what you desire. Make careful to
insert a row break by selecting a cell in column A or a column break by
selecting a cell in row 1.

 

Manual versus automatic page breaks
There is a small visual difference between manual and automated page
breaks in Normal mode. The dashed line indicating a manual page break is
more apparent than the line indicating an automated page break.

To have a clearer view of page breaks, go to View, Page Break Preview
and choose Page Break Preview mode. Automatic page breaks are shown



as dotted blue lines in this mode. Manual page breaks are represented by
solid lines.

 

Making adjustments using Page Break Preview
Page Break Preview mode has the benefit of allowing you to move a page
break by dragging the line connected with the page break. When you drag
an automated page break to increase the number of rows or columns on a
page, Excel adjusts the Scale % for all pages.

 

Removing manual page breaks
To remove a manual page break for a row, do the following:

1. Place your cursor on the row below the page break.

2. Select Page Setup, Breaks, and Remove Page Break from the
Page Layout tab.

 

To remove a manual page break for a column, do the following:

1. Place your pointer in the column to the right of the page break.

2. Select Page Setup, Breaks, and Remove Page Break from the
Page Layout tab.

(NB: Select Page Setup, Breaks, Reset Any Page Breaks from the Page
Layout tab to eliminate all manual page breaks. It’s worth noting that
removing the page breaks returns the scale to 100%).

 



How to find print settings
In Excel, you can change the print settings or page setup at least nine times.
The most frequent duties may be found in a variety of areas. You may, for
example, modify the margins in five of the nine spots. Four of the nine
locations allow you to adjust the paper size and orientation.

When you get to the more esoteric settings, you may only be able to
discover them in one or two locations. You can find out where you may be
able to adjust the setting for every specific job.

 

 

Here’s where you can locate each location:

File > Print: To show the Print panel, open the File menu and
choose Print. This panel contains Printer and Page Setup options in
the middle, as well as a huge Print Preview on the right.

 

The Ribbon’s Page Layout Tab: In the ribbon, choose the Page
Layout tab. Printing is divided into three categories: Page Setup,
Scale to Fit, and Sheet Options.

 

Page Setup Dialog: To open the classic Page Setup dialog box,
click the diagonal arrow icon in the lower-right corner of the three
groups in the Page Layout ribbon tab. There are four tabs in this
dialog box. The tab is identified by the superscript next to each
bullet: 1 for Page, 2 for Margins, 3 for Header/Footer, and 4 for



Sheet. This dialog box may also be accessed by selecting the Print
Titles button in the Page Layout tab of the ribbon.

 

Page Layout View: On the View tab, choose Page Layout. This
indicator may also be seen in the bottom right corner of the Excel
screen.

 

Header & Footer Tools Design Tab: On Page Layout view, select
one of the three header or footer zones on any page to bring up the
Header & Footer Tools Design tab in the ribbon. It is important to
note that in order to leave Page Layout view, you must first click
outside of the header or footer zones. Although this is the most
concealed option, it provides a more convenient approach to adjust
headers and footers.

 

Preview of Page Breaks View: On the View tab, choose Page
Break Preview. This symbol may also be seen in the bottom right
corner of the Excel window.

 

Printer Properties Dialog: To open the Print panel, use Ctrl+P.
Just below the printer name, a link to Printer Properties appears.

 

Excel Options: Select Options, Advanced from the File menu.
After you’ve done a Print Preview, this is the sole area where you
may disable the display of automatic page breaks.

 



Print Preview Full Screen: Drag this icon to the Quick Get
Toolbar to access a full-screen version of Print Preview akin to
prior Excel versions.

 

Printing with a single click
If you’re a keyboard fanatic, you may be annoyed that Ctrl+P in Excel
brings you to the Print panel rather than completing a rapid print. Quick
Print, can, however, be restored to Excel in a few simple steps.

 

 

 

The Quick Access Toolbar (QAT) is a row of tiny icons located
immediately above or below the ribbon. A drop-down menu is located on
the right side of this toolbar. To show a brief list of common commands, use



the drop-down menu at the right edge of the Quick Access Toolbar. Select
Quick Print.

When you click the Quick Print button, Excel sends one copy of the
current worksheet to the last printer you used. The worksheet is sent to the
default printer if you have not previously printed in this Excel session.

Although this restores Quick Print as a mouse click, it is still inconvenient
for keyboard-centric users. On Excel, pressing and releasing the Alt key
displays a row of shortcuts for the first nine items in the Quick Access
Toolbar.

 

Using the File menu to print
To reach the Print panel, choose File > Print, or press Ctrl+P. The panel
combines options from the Print and Page Setup dialog boxes in the centre
of the screen, as well as the Print Preview on the right. As you change the
settings in the centre of the screen, the Print Preview changes, allowing you
to always see the most recent preview.



The left side of the screen is dominated by a huge Print button. To print the
document, click this button. You can adjust the number of copies to print by
spinning the spin button next to the Print button.

(NB: The remainder of the left panel is devoted to a new kind of gallery.
Without opening the gallery, you may view the current selection. There is
no need to access the drop-down menu if the relevant printer is already
chosen).



 

Choosing a Printer
Excel shows all the existing printers and indicates whether or not the printer
is presently online and/or accessible when you enter the Printer drop-down
menu. This useful enhancement allows you to identify whether the
department printer is jammed and print to a new printer.

 

Viewing the Page Layout
The Normal view is the default view when you start Excel. The only
options in previous versions of Excel were Normal view and Page Break
Preview mode. However, starting with Excel 2007, Microsoft introduced
the Page Layout view, which is useful when preparing a document for
printing. (NB: The three views in Excel may be found on the View tab or
on the right side of the status bar).

You have a fully functional worksheet in Page Layout view. The formula
bar, for example, works, and you can browse around the worksheet.
However, the following are the distinctions between Page Layout and
Normal view:

On each page, white space appears to illustrate the margins. This is
typically advantageous since you can see any page gaps between
columns or rows. If you wish to conceal the white space, right-click
it and choose Hide White Space.

A ruler appears underneath the formula bar, which you can use to
modify margins by moving the ruler’s gray regions.



Areas are labeled Add a Header and a Footer by clicking the
Add a Header and Add a Footer buttons. Whereas headers and
footers are hidden in previous versions of Excel, they are clearly
visible in the Page Layout view of Excel.

Click to Add Data is shown in areas of a worksheet that are not in
the data area. One issue with the Page Break Preview mode was that
sections outside of the data area were grayed out. (NB: The Click to
Add Data Labels option, on the other hand, enables you to
continue adding pages to your spreadsheet).

(NB: The sole downside of using Page Layout view is that it disables your
Freeze Panes settings. Excel alerts you to the fact that this is occurring.
Excel employs this to underline the distinction between Print Titles and
Freeze Panes).

 

How to choose what to print
Active Sheets, Entire Workbook, and Selection options are available in the
Print What gallery. You can further customize these options by selecting
Ignore Print Area.

When you pick Active Sheets, the currently chosen sheet is printed. If you
specify a print area, just that range is printed; otherwise, Excel displays the
whole document’s usable range. When you pick several sheets in Group
mode, however, all of the chosen sheets print.

 



When you choose the Entire Workbook option, all no hidden worksheets in
the workbook are printed. One benefit of this choice is that the pages are
sequentially numbered as the printing progresses from Sheet1 to Sheet2.

By selecting the Selection option, you can temporarily override the print
area. If you just need to print a tiny portion of a huge report, choose that



portion and then select the Selection option in the Print What gallery. (NB:
This saves you from changing the Print Area repeatedly).

The Ignore Print Area option instructs Excel to disregard any previously
set print zones. The full utilized area of the worksheet is printed as a result
of this.

Using the Pages spin buttons, you may print selected pages. Enter the page
number in both the Pages and To boxes to print a single page.

 

Changing Printer Settings
The remaining galleries on the left side of the Print panel are repainted once
you choose a printer. Use the gallery to pick each of these choices if you are
printing to an office printer that supports collating and stapling. Excel does
not display the galleries if you print to a home printer that does not have
these settings.

 

Changing a few of the Page Setup options
Despite their appearance, the final options on the left side of the Print panel
are used to manage portrait vs landscape, paper size, and margins. If you
make a modification here, it will be reflected in the Page Setup dialog box.

If you’re wondering why these settings are duplicated here, you may also be
wondering why your preferred Page Setup options aren’t. Although it is
convenient to go from portrait to landscape mode here, it would be much
more convenient to be able to modify the Page Scaling or Rows to Repeat
At Top options. However, this is not possible since such adjustments need
closing the Print panel and using the Page Layout tab of the ribbon.



 

Exploring other page setup options
Other page layout options can be found throughout the various interface
areas. Although some of these are obscure, you may need to use them in
certain circumstances.

 

Printing gridlines and headings
Select Sheet Options > Gridlines > Print from the Page Layout tab to
print the gridlines on a worksheet.

The A-B-C column headings and the 1-2-3 row headings can also be
printed. To do so, go to the Page Layout tab and select Sheet Options,
Headings, and Print. When printing formulas with the FORMULATEXT
function and need to see the cell address of each cell, this option comes in
handy.

 

Centering a small report on a page
Small reports that are printed in the upper-left corner of a page may appear
out of place. Instead of expanding the margins, you can center the report
horizontally or vertically on a page.

 

To open the Page Setup dialog box, choose Page Layout, Margins, and
Custom Margins. At the bottom of the dialog box, there are two check
boxes that allow you to center the report on the page.



 

Replacing error values when printing
Excel computations may sometimes produce mistakes such as #N/A! or
DIV/0. Although these error numbers assist you in determining how to
correct the issues, they seem out of place on a printed page. You have the
option of replacing any mistake cells with a blank or two hyphens.

To access the Sheet tab of the Page Setup dialog box, choose Page Layout,
Print Titles. Select blank> or — from the Cell Errors As drop-down
option.

 

Printing comments

Cell comments are often shown as a little red triangle in a cell. At the
conclusion of your report, you can print a table with all the comments.
Choose At End Of Sheet from the Comments And Notes drop-down
menu on the Sheet tab of the Page Setup dialog box.

Excel produces your report and then opens a new page with each
comment/note listed. The new page displays the cell as well as the
comment/note content.

The other option for printing comments and notes is to print any visible
ones that are currently visible where they are displayed. Select Review,
Notes, and Show All Notes to see them all. When they are visible, you can
drag them to a new location so that they do not obscure important cells.

 

Controlling the first page number



It’s possible that you’re putting a printed Excel spreadsheet in the midst of a
printed Word document. If the Excel worksheet appears on the tenth page of
the Word report, for example, you’d want the Excel page numbers to begin
at 10 rather than 1.

Select the dialog box launcher at the bottom right of the Page Setup group
from the Page Layout tab. The Page tab of the Page Setup dialog box is
displayed in Excel. The last option is First Page Number, which is
originally set to Auto. If you enter 10 in this field, Excel will print the
Excel worksheet with page numbers 10, 11, 12, and so on.



 

CONCLUSION
The new Microsoft Excel 2022 is equipped with a whole lot of new features
and enhancements much more than its predecessor (Microsoft Excel 2021).
This version of Microsoft Excel comes alongside Microsoft Office 365 and
its collaboration makes Excel 2022 a very unique software.

In this guide, users will learn the fundamentals regarding Excel like
creating pivot tables, learn about worksheets and workbooks, creating links
between worksheets, use formulas to join text use keyboard accelerators,
using date math, how to use AutoSum and so much more.

At the end of this guide, users will fully understand Microsoft Excel 2022
and get to begin using the software on their own and with their companies.
Going further, the Microsoft Excel 2022 User Guide includes updated
information and an up-to-date step-by-step guide to make your adventure of
acquiring and learning Excel 2022 functionalities more enjoyable.

If you are a business or individual worker who wants to learn how to create
tables, organize, and manage data, you need to purchase this Microsoft
Excel 2022 User Guide and start your incredible journey.
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